Pig
  1. Pig
  2. PIG-1033

javac warnings: deprecated hadoop APIs

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.4.0
    • Fix Version/s: 0.6.0
    • Component/s: impl
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      Suppress javac warnings related to deprecated hadoop APIs.

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          2d 19h 15m 1 Daniel Dai 23/Oct/09 20:42
          Resolved Resolved Closed Closed
          152d 1h 33m 1 Alan Gates 24/Mar/10 22:15
          Alan Gates made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Alan Gates made changes -
          Assignee Daniel Dai [ daijy ]
          Daniel Dai added a comment -

          Not sure if this blanket suppression of deprecation javac warnings is good. See the same discussion on MAPREDUCE side, link to it for reference.

          Daniel Dai made changes -
          Link This issue is related to MAPREDUCE-623 [ MAPREDUCE-623 ]
          Daniel Dai made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Hadoop Flags [Reviewed]
          Resolution Fixed [ 1 ]
          Daniel Dai added a comment -

          Patch committed.

          Olga Natkovich added a comment -

          +1

          Daniel Dai made changes -
          Field Original Value New Value
          Attachment PIG-1033-1.patch [ 12423039 ]
          Olga Natkovich added a comment -

          I think it is ok to go with the option 1 for now with the understanding that we clean things up as part of the transition to Hadoop 21

          Daniel Dai added a comment -

          We have options:
          1. Change build.xml to disable deprecation warnings. BTW, hadoop does not check for deprecation when compiling
          2. Using @SuppressWarnings("deprecation") to suppress specific blocks. The problem is we cannot suppress import block, all import warnings still there
          3. Using @SuppressWarnings("deprecation") and do not import deprecate class. Use full qualified class name for deprecate class when using it. The downside is patch is relatively lengthy.

          Daniel Dai created issue -

            People

            • Assignee:
              Daniel Dai
              Reporter:
              Daniel Dai
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development