Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-6489

Adopt PQS ITs to use Phoenix 5.1

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: queryserver-6.0.0
    • Fix Version/s: queryserver-6.0.0
    • Component/s: queryserver
    • Labels:
      None

      Description

      Now that we have 5.1 releases, it makes sense to build and test PQS agains the latest release.

      As there are incompatible changes in the test classes between 5.0 and 5.1, as well as 4.15 and 4.16, we also need to give up running the ITs with older Phoenix versions.

      HBase minicluster shading issues still make running the ITs against HBase 1.x impossible.

      In fact, running the ITs with non-default Phoenix versions is more trouble than it is worth, so it's best to remove the explicit support for running with non-default versions.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                stoty Istvan Toth
                Reporter:
                stoty Istvan Toth
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: