Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-6177

Queryserver Avatica and Jetty versions are incompatible

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: queryserver-6.0.0
    • Fix Version/s: queryserver-6.0.0
    • Component/s: queryserver
    • Labels:
      None

      Description

      We have updated Jetty to the latest in queryserver, but Avatica has known compatibility issues with Jetty>=9.4.19, and the fix is only available in the unreleased 1.18 version.

      We must not release queryserver in this state.

      If Avatica 1.18 is not released in the meantime, we must downgrade Jetty to a pre-9.4.19 version.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              stoty Istvan Toth
              Reporter:
              stoty Istvan Toth

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment