Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-5829

Make it possible to build/test queryserver against all supported versions

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: queryserver-6.0.0
    • Fix Version/s: queryserver-6.0.0
    • Component/s: queryserver
    • Labels:
      None

      Description

      The queryserver repo is currently building against Phoenix 4.14-2.

      Trying to build it against master doesn't work.
      While theoretically the resulting artifacts should work both with 4.x and master, it is not possible to run the tests with master.

      Fix the build process so that the repo can built -and tested - with both 4.15+ and master, and document how to do this.

        Attachments

        Issue Links

          Activity

            People

            • Assignee:
              stoty Istvan Toth
              Reporter:
              stoty Istvan Toth

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment