Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-5656

Make Phoenix scripts work with Python 3

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.1.0, 4.16.0
    • Component/s: None
    • Labels:
      None

      Description

      Python 2 is being retired in some environments now. We should make sure that the Phoenix scripts work with Python 2 and 3.

        Attachments

        1. 5656-4.x-HBase-1.5-untested.txt
          22 kB
          Lars Hofhansl
        2. 5656-4.x-HBase-1.5-v3.txt
          4 kB
          Lars Hofhansl
        3. 5656-4.x-HBase-1.5-v4.txt
          23 kB
          Lars Hofhansl
        4. PHOENIX-5656.4.x.v1.patch
          24 kB
          Richárd Antal
        5. PHOENIX-5656.4.x.v2.patch
          48 kB
          Richárd Antal
        6. PHOENIX-5656.4.x.v3.patch
          47 kB
          Richárd Antal
        7. PHOENIX-5656.4.x.v4.patch
          47 kB
          Richárd Antal
        8. PHOENIX-5656.4.x.v5.patch
          48 kB
          Richárd Antal
        9. PHOENIX-5656.master.v1.patch
          18 kB
          Richárd Antal
        10. PHOENIX-5656.master.v2.patch
          49 kB
          Richárd Antal
        11. PHOENIX-5656.master.v3.patch
          47 kB
          Richárd Antal
        12. PHOENIX-5656.master.v4.patch
          47 kB
          Richárd Antal
        13. PHOENIX-5656.master.v5.patch
          48 kB
          Richárd Antal
        14. PHOENIX-5656.master.v6.patch
          21 kB
          Istvan Toth

          Issue Links

            Activity

              People

              • Assignee:
                richardantal Richárd Antal
                Reporter:
                larsh Lars Hofhansl
              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: