Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-4677

Commons-cli needs to be listed as dependency.

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.14.0, 5.0.0
    • Labels:
      None

      Description

      After HBase upgraded to hbase-thirdparty 2.1.0 via HBASE-20223, it shaded its dependency on commons-cli. Phoenix has apparently be transitively using this dependency without explicitly declaring it.

      We need to own the dependencies that we require.

        Attachments

        1. PHOENIX-4677.001.patch
          4 kB
          Josh Elser

          Activity

            People

            • Assignee:
              elserj Josh Elser
              Reporter:
              elserj Josh Elser
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: