Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-4649

Phoenix Upsert..Select query is not working for long running query.But while we ran same query with limit clause then it works fine

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 4.11.0
    • 5.0.0-alpha
    • None
    • Important

    Description

      We have data in table A which is around 3 Million Records. and from this table we have upsert data in to table B with out limit clause.

      (Note : Here we already export the hbase conf path and set all phoenix properties to mentioned value and both the tables are salted)

      Please find following hbase-site.xml screen shot.

      But hbase conf was not picked up when we launch sqlline/psql.

      Please refer following screenshot 

      And when we ran same query with setting limit clause which is higher than total number record present in table A,it runs absolutely fine with out giving any error. 

       

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            Unassigned Unassigned
            nitinchunke15 Nitin D Chunke

            Dates

              Created:
              Updated:

              Slack

                Issue deployment