Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-3336

get the wrong results when using the local secondary index

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • 4.8.0
    • None
    • None
    • hbase-1.1.2

    • Important

    Description

      When using phoenix local secondary index, two clients concurrent upsert data to the same row key, while the other client using the index column to retrieve data, it gets the wrong results.

      Just like the attachments, I create one table called orders_5, and create one local index on table orders_5, called clerk_5; then I use two clients to upsert data to the same row key of table orders_5, and you will see that, the local index clerk_5 have some stale record (maybe its OK for eventual consistency), however, when you use the previous value to retrieve the record, you can still get the result, even more serious, the result is wrong, namely it not the record which you have insert before, and also not the record in the primary table(in the case ,is the table orders_5)

      Attachments

        1. wrong-index-2.png
          105 kB
          Houliang Qi
        2. create_table_orders.sql
          0.5 kB
          Houliang Qi
        3. readme.txt
          1.0 kB
          Houliang Qi
        4. sample_1.csv
          107 kB
          Houliang Qi
        5. sample_2.csv
          106 kB
          Houliang Qi

        Activity

          People

            Unassigned Unassigned
            houliang Houliang Qi
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:

              Time Tracking

                Estimated:
                Original Estimate - 120h
                120h
                Remaining:
                Remaining Estimate - 120h
                120h
                Logged:
                Time Spent - Not Specified
                Not Specified