Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-302

Disable usage of essential column family in 0.94.6 and below

Attach filesAttach ScreenshotVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Task
    • Status: Resolved
    • Resolution: Fixed
    • None
    • None
    • None
    • 171

    Description

      The essential column family feature makes queries slower in 0.94.6 and below. We should add a configuration option to disable it. It's enabled in QueryCompiler by setting the LOAD_COLUMN_FAMILIES_ON_DEMAND_ATTR to true.

      Ideally, we should detect the lower HBase region server version. We could pass this back at initial cluster connection (MetaDataProtocol.getVersion() call).

      Another option would be to have the config option, set it to on by default, but let users know that if they're using 0.94.6 or below, then should set it to off.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            tonyhuang tonyhuang
            jamestaylor James R. Taylor
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Slack

                Issue deployment