Uploaded image for project: 'Phoenix'
  1. Phoenix
  2. PHOENIX-1530

Phoenix 4.2.2 not buildable in BigTop

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 4.2.0
    • Fix Version/s: None
    • Labels:
      None

      Description

      As http://phoenix.apache.org/recent.html indicates Phoenix is included in BigtTop. I expect each minor release would also be supported in Bigtop. An RPM is critical for auto-deploying Phoenix into our run-time environment.

      But, 4.2.2 does not build due to snappy dependency issues.

      [INFO] ------------------------------------------------------------------------
      [WARNING] The POM for org.iq80.snappy:snappy:jar:1.0.4.1 is missing, no dependency information available
      [INFO] ------------------------------------------------------------------------
      [INFO] Reactor Summary:
      [INFO]
      [INFO] Apache Phoenix .................................... SUCCESS [4.173s]
      [INFO] Phoenix Core ...................................... FAILURE [2.799s]
      [INFO] Phoenix - Flume ................................... SKIPPED
      [INFO] Phoenix - Pig ..................................... SKIPPED
      [INFO] Phoenix Assembly .................................. SKIPPED
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 7.834s
      [INFO] Finished at: Mon Dec 15 14:13:38 UTC 2014
      [INFO] Final Memory: 20M/289M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal on project phoenix-core: Could not resolve dependencies for project org.apache.phoenix:phoenix-core:jar:4.2.2: Failure to find org.iq80.snappy:snappy:jar:1.0.4.1 in https://repository.apache.org/content/repositories/releases/ was cached in the local repository, resolution will not be reattempted until the update interval of apache release has elapsed or updates are forced -> [Help 1]
      [ERROR

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jchabot72 Jerry Chabot
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: