Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.2
    • Fix Version/s: 1.8.3, 2.0.0
    • Component/s: Preflight
    • Labels:
      None
    • Environment:
      RedHat Linux

      Description

      ./Non-PFDA/a7060f.pdf :: Exception in thread "main" org.apache.pdfbox.preflight.exception.ValidationException: Failed while validating
      at org.apache.pdfbox.preflight.process.MetadataValidationProcess.validate(MetadataValidationProcess.java:154)
      at org.apache.pdfbox.preflight.utils.ContextHelper.callValidation(ContextHelper.java:74)
      at org.apache.pdfbox.preflight.utils.ContextHelper.validateElement(ContextHelper.java:88)
      at org.apache.pdfbox.preflight.PreflightDocument.validate(PreflightDocument.java:168)
      at org.apache.pdfbox.preflight.Validator_A1b.runSimple(Validator_A1b.java:158)
      at org.apache.pdfbox.preflight.Validator_A1b.main(Validator_A1b.java:125)
      Caused by: org.apache.pdfbox.preflight.exception.ValidationException: Cannot treat Document Information CreationDate property
      at org.apache.pdfbox.preflight.metadata.SynchronizedMetaDataValidation.formatAccessException(SynchronizedMetaDataValidation.java:525)
      at org.apache.pdfbox.preflight.metadata.SynchronizedMetaDataValidation.analyzeCreationDateProperty(SynchronizedMetaDataValidation.java:352)
      at org.apache.pdfbox.preflight.metadata.SynchronizedMetaDataValidation.validateMetadataSynchronization(SynchronizedMetaDataValidation.java:482)
      at org.apache.pdfbox.preflight.process.MetadataValidationProcess.validate(MetadataValidationProcess.java:82)
      ... 5 more
      Caused by: java.io.IOException: Error converting date:êÝ·µ{áÊmÑÀ˜hł†Í
      at org.apache.pdfbox.util.DateConverter.toCalendar(DateConverter.java:294)
      at org.apache.pdfbox.util.DateConverter.toCalendar(DateConverter.java:168)
      at org.apache.pdfbox.cos.COSDictionary.getDate(COSDictionary.java:797)
      at org.apache.pdfbox.pdmodel.PDDocumentInformation.getCreationDate(PDDocumentInformation.java:210)
      at org.apache.pdfbox.preflight.metadata.SynchronizedMetaDataValidation.analyzeCreationDateProperty(SynchronizedMetaDataValidation.java:347)
      ... 7 more

      1. a7060f.pdf
        90 kB
        William Fausser
      2. PDFBox-1630.patch
        4 kB
        Eric Leleu

        Activity

        Eric Leleu added a comment -

        Hi,

        Interesting problem indeed.
        At first look, it seems to be an encoding issue but I think it is due to the encryption element of the PDF.

        I need to look in depth to confirm that point because I'm not familiar with the PDF encryption feature.

        BR,
        Eric

        Eric Leleu added a comment -

        Hi,

        According to the PDF reference every String can be encoded in a PDF excepted Strings of the trailer ID and elements of the Encrypt dictionary.

        I handled the error and create the validation code 7.12 (Dictionary Info Corrupt)

        In attachment the patch that fixes the problem.
        I have committed this patch in the trunk under the revision r1497532.

        BR,
        Eric

        Andreas Lehmkühler added a comment -

        Merged into 1.8-branch in revision 1542711

        Andreas Lehmkühler added a comment -

        Closed after releasing 1.8.3


          People

          • Assignee:
            Eric Leleu
            Reporter:
            William Fausser
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development