Uploaded image for project: 'PDFBox'
  1. PDFBox
  2. PDFBOX-1587

Update the dependency on Bouncy Castle to 1.48

VotersWatch issueWatchersLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 1.8.1
    • 2.0.0
    • None
    • None

    Description

      The recent versions of Bouncy Castle didn't preserve the binary compatibility and PDFBox doesn't compile against them.

      This is an issue for the Debian project because the Bouncy Castle package has to be updated to 1.48 in order to fix a security issue. This update is going to break the PDFBox package.

      Could you please update the dependency on Bouncy Castle? I'll attach the patch with the necessary changes.

      Attachments

        Activity

          This comment will be Viewable by All Users Viewable by All Users
          Cancel

          People

            tchojecki Thomas Chojecki
            ebourg Emmanuel Bourg
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Issue deployment