PDFBox
  1. PDFBox
  2. PDFBOX-1235

Exception in thread "main" java.util.zip.ZipException: unknown compression method

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Exception in thread "main" java.util.zip.ZipException: unknown compression method
      at java.util.zip.InflaterInputStream.read(Unknown Source)
      at org.pdfbox.filter.FlateFilter.decode(FlateFilter.java:97)
      at org.pdfbox.cos.COSStream.doDecode(COSStream.java:290)
      at org.pdfbox.cos.COSStream.doDecode(COSStream.java:243)
      at org.pdfbox.cos.COSStream.getUnfilteredStream(COSStream.java:170)
      at org.pdfbox.pdmodel.common.PDStream.createInputStream(PDStream.java:226)
      at org.pdfbox.pdmodel.common.PDStream.getByteArray(PDStream.java:481)
      at org.pdfbox.pdmodel.graphics.xobject.PDPixelMap.getRGBImage(PDPixelMap.java:138)
      at com.phani.PDFTextParser.read_pdf(PDFTextParser.java:143)
      at com.phani.PDFTextParser.main(PDFTextParser.java:108)

        Activity

        Andreas Lehmkühler made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        John Hewson made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        John Hewson added a comment -

        Closing due to inability to reproduce.

        Andreas Lehmkühler added a comment -

        I can't confirm the described behaviour. It works fine using PDFReader and ExtractImage. I've tried every version from 1.2.1 up to the current trunk.

        Which version of PDFBox are you using?

        phani kumar janapati made changes -
        Field Original Value New Value
        Attachment Golden32.pdf [ 12515583 ]
        phani kumar janapati added a comment -

        On Wed, Feb 22, 2012 at 5:45 PM, Andreas Lehmkühler (Commented) (JIRA) <

        Regards,
        Phani Kumar
        8099527537

        Andreas Lehmkühler added a comment -

        Can you provide us with a sample pdf, please?

        phani kumar janapati created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            phani kumar janapati
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development