Uploaded image for project: 'OpenWebBeans'
  1. OpenWebBeans
  2. OWB-817

the jsf module(s) are bound to a specific el version

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.8, 1.2.0
    • Fix Version/s: 1.2.0
    • Component/s: Java EE Integration
    • Labels:
      None

      Description

      <artifactId>openwebbeans-jsf</artifactId>
      and
      <artifactId>openwebbeans-jsf12</artifactId>

      shouldn't contain the el-resolver config for jsf (see faces-config.xml), because it's possible to re-configure the el version (which should be used by the jsf impl.).

      instead it should be packaged with
      <artifactId>openwebbeans-el10</artifactId>
      and
      <artifactId>openwebbeans-el22</artifactId>

        Attachments

        1. OWB-817.patch
          4 kB
          Gerhard Petracek

          Activity

            People

            • Assignee:
              gpetracek Gerhard Petracek
              Reporter:
              gpetracek Gerhard Petracek
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: