OpenWebBeans
  1. OpenWebBeans
  2. OWB-615

remove @Overrides for interfaces to be java5 compatible

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.1.2
    • Component/s: Core
    • Labels:
      None

      Description

      we switched to Java5 source and target but still have the @Overrides for interfaces in our code. This creates tons of compat warnings in Idea and Eclipse.

      We also need to review if we don't use String.isEmpty() and other java6 stuff.

        Activity

        Mark Struberg created issue -
        Mark Struberg made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Hide
        Mark Struberg added a comment -

        shipped in OpenWebBeans-1.1.2

        Show
        Mark Struberg added a comment - shipped in OpenWebBeans-1.1.2
        Mark Struberg made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Mark Struberg
            Reporter:
            Mark Struberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development