Uploaded image for project: 'OpenWebBeans'
  1. OpenWebBeans
  2. OWB-615

remove @Overrides for interfaces to be java5 compatible

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.1.1
    • Fix Version/s: 1.1.2
    • Component/s: Core
    • Labels:
      None

      Description

      we switched to Java5 source and target but still have the @Overrides for interfaces in our code. This creates tons of compat warnings in Idea and Eclipse.

      We also need to review if we don't use String.isEmpty() and other java6 stuff.

        Attachments

          Activity

            People

            • Assignee:
              struberg Mark Struberg
              Reporter:
              struberg Mark Struberg
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: