OpenWebBeans
  1. OpenWebBeans
  2. OWB-596

Provide info about injetion point for "Passivation capable beans must satisfy passivation capable dependencies ..."

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 1.1.4
    • Component/s: None
    • Labels:
      None

      Description

      Mesage from AbstractOwbBean.validatePassivationDependencies(): org.apache.webbeans.exception.WebBeansConfigurationException: Passivation capable beans must satisfy passivation capable dependencies. Bean : Name:myBean,WebBeans Type:MANAGED,API Types:[java.lang.Object,java.io.Serializable,],Qualifiers:[javax.enterprise.inject.Any,javax.enterprise.inject.Default,javax.inject.Named] does not satisfy.

      does not provide info about the injection point. It would be nice to have this info in some format for fast navigation (for example [1] )

      [1] http://download.eclipse.org/eclipse/downloads/drops/R-3.7-201106131736/eclipse-news-part2.html#JavaEditor, section Open Java element from clipboard

        Activity

        No work has yet been logged on this issue.

          People

          • Assignee:
            Martin Kočí
            Reporter:
            Martin Kočí
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development