OpenWebBeans
  1. OpenWebBeans
  2. OWB-305

exceptions become InvocationTargetException when propogated up interceptor stack

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: M3
    • Fix Version/s: M4
    • Labels:
      None

      Description

      Currently, each interceptor beans invocation is separated by calls to Method.invoke() which wraps checked exceptions in InvocationTargetException, but the interceptor spec says downstream interceptors must see the actual exception.

      We can pull the cause out of the InvocationTargetException back in InvocationContextImpl.proceeed() and throw the cause instead.

      This is needed for e.g. org.jboss.jsr299.tck.interceptors.tests.aroundInvoke.exception

        Activity

        Eric Covener created issue -
        Eric Covener made changes -
        Field Original Value New Value
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Fixed [ 1 ]
        Mark Struberg added a comment -

        closed all issues which got resolved in M4

        Mark Struberg made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Eric Covener
            Reporter:
            Eric Covener
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 4h
              4h
              Remaining:
              Remaining Estimate - 4h
              4h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development