Uploaded image for project: 'Openmeetings'
  1. Openmeetings
  2. OPENMEETINGS-369

Please make the "Clear Whiteboard" tool only accessible to Moderators and not to participants who have “Draw on the Whiteboard” rights

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.0 Apache Release
    • Fix Version/s: 4.0.0
    • Labels:
      None
    • Environment:
      OpenMeetings 2.x

      Description

      Please make the "Clear Whiteboard" tool only accessible to Moderators and not to participants who have “Draw on the Whiteboard” rights as this tool clears the entire whiteboard.

      Instead of making this right a Moderator only feature, it may be better to create a "User is a Presenter" option and to control access for all the below rights (Note: a moderator would inherit these rights by default).
      OPENMEETINGS-369 - Please make the "Clear Whiteboard" tool only accessible to Moderators and not to participants who have “Draw on the Whiteboard” rights
      OPENMEETINGS-370 - Please make the ability to change slides/pages of an uploaded document only available to Moderators, and not to participants who have “Draw on the Whiteboard” rights
      OPENMEETINGS-371 - Please make the ability to create new Whiteboards or change the Whiteboard only available to Moderators, and not to participants who have “Draw on the Whiteboard” rights has been successfully created.
      OPENMEETINGS-374 - Only Moderators should have the ability to upload, add, delete, or load files and folders.

        Activity

        jira-bot ASF subversion and git services added a comment -

        Commit c59c2dccc81ee4666ad35acad484a0f927c6fcff in openmeetings's branch refs/heads/master from Maxim Solodovnik
        [ https://git-wip-us.apache.org/repos/asf?p=openmeetings.git;h=c59c2dc ]

        OPENMEETINGS-369 english strings are added to other languages

        jira-bot ASF subversion and git services added a comment -

        Commit 25c24ebc370c737225b8d786f18f1d29ec7baf4f in openmeetings's branch refs/heads/master from Maxim Solodovnik
        [ https://git-wip-us.apache.org/repos/asf?p=openmeetings.git;h=25c24eb ]

        [OPENMEETINGS-369,OPENMEETINGS-371,OPENMEETINGS-1613] presenter role is added, basic role separation is added

        jira-bot ASF subversion and git services added a comment -

        Commit 1793245 from Maxim Solodovnik in branch 'application/trunk'
        [ https://svn.apache.org/r1793245 ]

        [OPENMEETINGS-369,OPENMEETINGS-371,OPENMEETINGS-1613] presenter role is added, basic role separation is added

        solomax Maxim Solodovnik added a comment -

        The only use case "date and time restriction" are in charge are:
        1) calendar appointment
        2) room invitation

        In first case Appointment owner can access appointment room any time (no restrictions)
        The second case: teacher is being invited to won class is extremely weird

        This is why I need steps to reproduce your issue
        like this:
        1) login as user with ??? permission
        2) create room (how???) OR enter the room (with what settings? what type?)
        3) ...........
        4) .........
        ....................

        jorgelondo Jorge Alberto Londoño Giraldo added a comment -

        Hi Maxim,

        An error that occurred in previous versions is that: if the students (users) entered before the teachers to the classroom the teacher was left without the permissions of moderator and it was the students (users) who had to enable the permissions to the teacher (moderator ).

        That is to say, the idea is that the teacher does not have a date and time restriction to be able to enter the class, since they must upload contents, files, to leave the class ok for the date and time indicated. So they can prepare their classes in advance, but the students can only enter at the time of the class (time and date programmed).

        solomax Maxim Solodovnik added a comment -

        Please provide steps to reproduce " in version 3.2.1 the schedule restriction is for both the Moderator (teacher) and for users"

        jorgelondo Jorge Alberto Londoño Giraldo added a comment -

        It is important to differentiate the roles of teachers and students:
        The thing about the erasing tool seems to me very well that it is only available to the moderators (teachers) but also
        It is important that the moderator of the class can enter at any time and has no time restriction, so that he can prepare the class and upload the necessary documents before class, in version 3.2.1 the schedule restriction is for both the Moderator (teacher) and for users, this restriction should be only for users (students).

        solomax Maxim Solodovnik added a comment -

        Hello George,

        As per my understanding your proposed "User is Presenter" role currently has name "Allow Draw"
        Could you please describe use case for the new Role? and how it is differ from current roles?

        I would propose to move this issues to 3.1 after some discussion in mailing lists?
        Is it OK?
        Could you start discussion?

        gkirkham George Kirkham added a comment -

        Removed request to apply fix to 2.0


          People

          • Assignee:
            solomax Maxim Solodovnik
            Reporter:
            gkirkham George Kirkham
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development