Openmeetings
  1. Openmeetings
  2. OPENMEETINGS-283

Choose devices - Start test recording - no longer plays back the recorded clip

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0 Apache Incubator Release
    • Component/s: BuildsAndReleases
    • Labels:
      None
    • Environment:
      Ubuntu, Debian, OpenMeetings 2.0 revision 1340587 and at least up to revision 1340879

      Description

      Choose devices - Start test recording - no longer plays back the recorded clip, the video window stays black, no sound is heard.
      since revision 1340587 and at least up to revision 1340879

      1. chinese simplified.txt
        149 kB
        George Kirkham
      2. ChineseLanguage.diff
        18 kB
        George Kirkham

        Activity

        Maxim Solodovnik added a comment -

        I can confirm
        The streams are stored as
        red5/webapps/openmeetings/11/streams/11/TEST_SETUP...
        I'll investigate

        Maxim Solodovnik added a comment -
        Maxim Solodovnik added a comment -

        The issue is partially fixed (FileNotFoundException is still appears in the log)
        Recordings are now playable

        George Kirkham added a comment -

        Diff file for Chinese text

        George Kirkham added a comment -

        Text file of the chinese simplified xml file, just in case the SVN Diff file is corrupted.

        George Kirkham added a comment -

        Maxim, I have compiled and installed revision 1342497 and the "Start test recording" of the "Choose devices" dialog in a conference room still cannot play back the 5 sec recording. Was this working for you?

        Maxim Solodovnik added a comment -

        yes it works as expected (The only issue is exception in the logs on stop playback)
        have you drop red5? ("ant clean.all" or "rm -rf build/red5")

        SebastianWagner added a comment -

        It does not playback the recorded clip at all. Neither initially nor when you hit the play button.
        I have run ant clean.all and re-installed. Debug and Non-Debug version show same behaviour.

        I will try to look at it now.

        SebastianWagner added a comment - - edited

        The playback of recordings also does not work anymore.
        Same if you upload a video to the File-Explorer => import works but playback on the whiteboard fails.
        It seems to me like Red5 has a bug in the video streaming.

        SebastianWagner added a comment -

        @Maxim Red5 r4371 does not seem to have the issue with the playback of flv's, however it contains other issues with the file stored at wrong position when doing a NetStream.record.
        Which revision of Red5 is the one that you need to update to in order for your API and RTMPS fixes?

        Maxim Solodovnik added a comment -

        I'll double check in Monday and will try to ask Red5 team to add additional fix for http://code.google.com/p/red5/issues/detail?id=214 (the second patch attached)
        Or I'll create another issue against it

        SebastianWagner added a comment -

        I have documentated the issue already to the Red5 mailing list:
        https://groups.google.com/forum/#!topic/red5interest/3mf8byJRCg8

        SebastianWagner added a comment -

        Funny but after reverting to r4374 Red5 I was not able to reproduce the error anymore. Everything was working just fine.
        I've tested with MacOSX, debian and windows acting as server. All ways where fine.
        Now we might just run some stability tests.

        Maxim Solodovnik added a comment -

        Recording are work for me (Except for java.io.FileNotFoundException: ServletContext resource ...) on streamPlayItemStop

        (should be fixed as soon as my second patch for Issue 214 will be commited to Red5)

        SebastianWagner added a comment -

        I think the issue is solved.
        The other problems are connected to issues with red5 in general not with our implementation.

        George Kirkham added a comment -

        Using the "Start recording test" feature of the "Choose devices" dialog window, I am unable to see the play back the 5 sec video recording. When I select the "Play" button, the video window remains black and there is not sound.

        I will wait for a later revision and try testing again. Today when I attempted an svn update, the install would not succeed, and the om log file contained "Could not find key in configuration CONF_KEY: number.minutes.reminder.send", I think there is an issue with Revision 1346705 or similar.

        George Kirkham added a comment -

        The issue has been resolved, I personally had issues seeing the fix as I needed to run an “ant clean.all” before the “ant -Ddb=mysql” during my build process. thanks all for resolving this issue.


          People

          • Assignee:
            Maxim Solodovnik
            Reporter:
            George Kirkham
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development