Openmeetings
  1. Openmeetings
  2. OPENMEETINGS-270

MemoryLeak / Dead-Lock in FlvRecorderConverter

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.0 Apache Incubator Release
    • Fix Version/s: 3.0.3, 3.1.0
    • Component/s: None
    • Labels:
      None

      Description

      DEBUG 05-15 16:08:19.955 FlvRecorderConverter.java 113480470 96 org.openmeetings.app.data.flvrecord.converter.FlvRecorderConverter [taskExecutor-4] - ### Stream not yet written Thread Sleep -

      => The Thread does sleep endlessly. We need to find out what causes that error and how we can prevent it.
      First of all a more detailed trace is needed to identify those recording_Ids that are broken to try to find out what happened and how long the Converter hands in the loop.

      It can be criticial if it turns out that there is a general issue with the recording there.

        Activity

        SebastianWagner added a comment -

        I was able to find the Exception why it does not stop.
        However I am not sure yet about the reason as I cannot reproduce it.
        We will need to update the demo server with my latest changes and see if the problem persists

        Mikael Kurula added a comment -

        Hi!

        I just came across this problem on my server, and it is a definitive showstopper for my application of OpenMeetings. How can I help to debug the problem? (I'm new to OpenMeetings but know how to dig in logs etc.)

        Friendly greetings,
        Mikael

        Clifton Kazocha added a comment -

        Hi Sebastian,

        I am also experiencing this problem. One of our users is able to get this to happen reliably. They are using Sun Java 7 on Windows Vista. I set up a VM that matched this users computer and wasn't able to get OM2 stuck in the loop. I set up a remote session with this users to see that they weren't doing anything unusual to cause the issue. It could be a red herring but it seemed like I only got the loop when making a recording while screen sharing was turned on. I killed all processes on the users system that weren't essential to windows and after that I could successfully make recordings.

        The cause seems to be something on the client side but I haven't been able to cause this issue on any other computer. I've tested in Linux, OS X, Win XP, Win Vista, and Win 7.

        I had Openmeetings 2.0 installed on Ubuntu 10.04 but after a successful upgraded to 12.04 the issue persists. FFmpeg was compiled from the latest source.

        I hope this info helps!

        Thanks,
        Clif

        Mikael Kurula added a comment -

        Very interesting! Coming to think of it, I think I have also used screen sharing every time I got into the loop problem. Now I left out the screen sharing and I could record four videos consecutively without ending up in the loop.

        My clients have been Firefox in OS X 10.6.8 with flash player version 11.5.502.110. My server is a CentOS 6 with the following software versions:

        Name : ffmpeg
        Arch : x86_64
        Version : 0.6.5
        Release : 1.el6.rf
        Size : 6.9 M
        Repo : installed
        From repo : rpmforge

        java version "1.6.0_37" (Oracle)
        Java(TM) SE Runtime Environment (build 1.6.0_37-b06)
        Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01, mixed mode)

        Maxim Solodovnik added a comment -

        can you change ffmpeg version to 0.10.3 and try to reproduce this issue using latest nightly build?
        https://builds.apache.org/job/openmeetings/

        Mikael Kurula added a comment -

        I tried this now. Indeed this seems to work now. At least I got the video processed and viewable.

        Maxim Solodovnik added a comment -

        Should be fixed

        latest commit: Committed revision 1603707.


          People

          • Assignee:
            Maxim Solodovnik
            Reporter:
            SebastianWagner
          • Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development