Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.0.0
    • Component/s: HTML5/WhiteBoard
    • Labels:

      Description

      Hi, In previous versions of the platform, the teacher could enter at any time to prepare his class (upload necessary documents) but in this new version is restricted the time to enter, ie only can be entered at the time of the class, it would be possible Have a type of user "teachers" and another "student", in the case of the teacher would have permission to prepare their class at any time and the student could only enter at the time of the class.
      Thanks

        Activity

        jira-bot ASF subversion and git services added a comment -

        Commit 25c24ebc370c737225b8d786f18f1d29ec7baf4f in openmeetings's branch refs/heads/master from Maxim Solodovnik
        [ https://git-wip-us.apache.org/repos/asf?p=openmeetings.git;h=25c24eb ]

        [OPENMEETINGS-369,OPENMEETINGS-371,OPENMEETINGS-1613] presenter role is added, basic role separation is added

        solomax Maxim Solodovnik added a comment -

        'Presenter' role is added,
        I see no issues with room access, please re-open with steps to reproduce if still an issue

        jira-bot ASF subversion and git services added a comment -

        Commit 1793245 from Maxim Solodovnik in branch 'application/trunk'
        [ https://svn.apache.org/r1793245 ]

        [OPENMEETINGS-369,OPENMEETINGS-371,OPENMEETINGS-1613] presenter role is added, basic role separation is added

        solomax Maxim Solodovnik added a comment -

        I believe more details are required:

        Administrator: currently there is such role in OM, Administrator can create other users tune the system and he/she is "super moderator" in room by default

        Moderator: have all rights in the room

        User: have no rights by default *

        • The room should be "Moderated", otherwise first user entered will be moderator

        Any user can enter the room anytime
        The exception is "Appointment room" this room is available to the organizer all the time, and available only during effective start/end date to participants.

        Since 3.2.2 there is special "Group file storage" available for particular group of users only, this storage can be "restricted" (no edit by non admin is allowed)

        I guess you are proposing to extend this by adding new role? In this case this is related to https://issues.apache.org/jira/browse/OPENMEETINGS-369

        We can discuss it ...

        jorgelondo Jorge Alberto Londoño Giraldo added a comment -

        These are suggestions for classrooms with whiteboard "conference"
        User profiles and suggested permissions.

        <strong>Administrator: </strong>
        Only the administrator can delete folders from the recordings

        <strong>Teacher or Moderator:</strong>

        You can create classes in the calendar.
        You can not delete folders from the recordings. (This to avoid mistakes and losses of recordings by involuntary errors of the teachers).
        The teacher can enter at any time to the classes (this is so that you can upload the necessary files to prepare the class).

        <strong>Student or general user:</strong>

        The student can create classes in the calendar, can only visualize in those that are registered as assistant.
        The student can only enter at the time of the class and enter without having the moderator's privileges enabled (it is to prevent the student from entering before the teacher to the classroom and with moderator permissions, which implies that the teacher upon entering It does not remain as a moderator ... because currently if the one that enters first stays with permissions of moderator.

        Another problem that is avoided is to enter the student before and modify the files that the teacher prepared.

        solomax Maxim Solodovnik added a comment -

        Could you please describe your scenario step by step?
        What user type are you using?
        What room type?
        How are you creating room?


          People

          • Assignee:
            solomax Maxim Solodovnik
            Reporter:
            jorgelondo Jorge Alberto Londoño Giraldo
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development