OpenJPA
  1. OpenJPA
  2. OPENJPA-2074

Calling em.persist(...) on simple entity without relations, with null primary key, @GeneratedValue results in InvalidStateException, complaining about non-default primary key.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Duplicate
    • Affects Version/s: 2.1.1
    • Fix Version/s: None
    • Component/s: jpa
    • Labels:
      None
    • Environment:
      Windows 7, Apache Tomcat 5.5, Eclipse Indigo, OpenJPA plugin handles enhancement, JPA facet, JAX-RS facet

      Description

      Simple entity without any relations, INT primary key, mapped to Long in POJO.
      Entity annotated propery with @Id @GeneratedValue
      DMBS: MySQL with JDBC connection.

      I started tracking down the issue. I can't get accustomed with the code around it, but I write my experience: (line numbers are based on source release 2.1.1)
      org.apache.openjpa.kernel.StateManagerImpl:

      • Line 2966: It seems that the method call results in my entity's id field being assigned with a generated value.
      • Line 2967: Then in the for loop after that, we reach the same field (the primary key) again at some point, and at
      • Line 2968: assignField(i, true) eventually runs on the same code which assigned the Id the first time, which freaks out, as the field value is already set at this point.
        org.apache.openjpa.util.ApplicationIds:481 (seems to be a utility method for me)

      I cannot investigate further, however I am pretty confident that this is a bug somewhere in the logic, maybe inside StateManagerImpl#assignField method. I believe org.apache.openjpa.util.ApplicationIds:481 should not be invoked the second time, as it's not idempotent.

      The exception message:
      Primary key field org.inception.teacher4u.persistence.entity.User.userid of org.inception.teacher4u.persistence.entity.User@635e98be has non-default value. The instance life cycle is in PNewState state and hence an existing non-default value for the identity field is not permitted. You either need to remove the @GeneratedValue annotation or modify the code to remove the initializer processing.

        Issue Links

          Activity

          Rick Curtis added a comment -

          Can you please post the full stacktrace?

          Also, can you better describe the scenario that you are having problems with?

          Thanks,
          Rick

          Csaba Tűz added a comment - - edited

          I'm sorry but since I reported the bug heavy development occured, I had to switch to Hibernate, and I cannot afford the time right now to produce the stack trace for you.
          Sorry for the annoyance.

          Scenario:
          I have an entity class as basic as:
          @Entity
          @Table(name = "myentity")
          class MyEntity

          { @Id @GeneratedValue private Integer id; private String name; /* getter/setters */ ... }

          I instantiate it, set the field 'name', leave the field 'id' to be null, then persist it like:

          EntityManager em = emf.createEntityManager();
          em.getTransaction().begin();
          em.persist(newEntity);
          em.getTransaction().commit();
          em.close();

          Result: The exception in my previous post.
          Investigation results:

          • Id gets assigned with generated value correctly, and after that, it gets assigned again.
          • The code which assigns the generated value checks if field value is default or not, and for the second run it finds obviously that it isn't, that's where the exception is thrown.
          Kevin Sutter added a comment -

          I just linked this issue with OPENJPA-673. There has to be something more to this Issue than what's currently documented. The simple example provided is tested several times over in the OpenJPA Junit bucket. After doing some searching, I came across OPENJPA-673. The use of a Version column with an unexpected value makes some sense. But, I thought that issue was resolved recently as well (just couldn't find the JIRA yet). Since there are multiple JIRAs with similar results, we probably need to take a closer look.

          Rick Curtis added a comment -

          Csaba -

          When you say "OpenJPA plugin handles enhancement", can you please clarify? I suspect this is the same problem as OPENJPA-1879[1].

          Thanks,
          Rick

          [1] https://issues.apache.org/jira/browse/OPENJPA-1879

          Csaba Tűz added a comment -

          I installed the OpenJPA Eclipse Tools feature from this
          http://people.apache.org/~dwoods/openjpa/devtools/updatesite/
          update site.

          Then I followed instructions here
          http://openjpa.apache.org/openjpaeclipseenhancementbuilder.html

          Now I see, that this page lists known bugs. I didn't notice it when installing the thing.
          http://openjpa.apache.org/enhancement-with-eclipse.html

          Reading the bug OPENJPA-1879 it looks like you are totally right.

          Sorry for generating unnecessary noise.

          Rick Curtis added a comment -

          Closing as this is a duplicate of OPENJPA-1879.


            People

            • Assignee:
              Unassigned
              Reporter:
              Csaba Tűz
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development