OpenJPA
  1. OpenJPA
  2. OPENJPA-2042

Diagnostics for Application Managed EntityManagerFactory leaks.

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.0.4, 1.2.2, 2.0.1, 2.1.0
    • Fix Version/s: 1.2.3, 2.2.0
    • Component/s: None
    • Labels:
      None

      Description

      EntityManagerFactories can be leaked if they are created with the JSE bootstrap Persistence class and are never closed, causing an OutOfMemoryException.

      One possibility may be to log a warning or otherwise alert the developer when the number of unclosed EMF's reaches a certain threshold. An extra step could be taken here to track where the EMF's are being opened and which ones aren't being closed as to show the developer exactly where in the code the problem is occurring.

      There may be a possibility to eliminate this leak by making the references to the EMF's weak and let the garbage collector clean up the unclosed EMF's. However, in the case that other objects are being leaked as well, this change may make it harder to detect such leaks.

      I ran a simple test that creates a EMF from Persistence. It then creates and closes an EntityManger. A new EMF is then created without closing the old one, effectively "leaking" it. As expected, this results in an OutOfMemoryException. When using weak references on the EMF's, I was able to get the test to run all night without a trace of any heap growth. However, this is only a very simple test and a test with more Entities/Configurations/etc. may result in heap growth due to other objects being leaked(as mentioned earlier). My test case is attached.

      For comparison, I tried the same test on Hibernate and EclipseLink. Hibernate runs into the same OutOfMemoryException. EclipseLink does not.

      1. TestEMFMemoryLeak.java
        2 kB
        Jacob Nowosatka
      2. OPENJPA-2042.patch
        1 kB
        Jacob Nowosatka

        Activity

        Albert Lee added a comment -

        Close issue in preparation for 2.2.0 release.

        Rick Curtis added a comment -

        Committed revision 1198786 to trunk. I added a null check in PCRegistry to fix the following problem:

        Caused by: java.lang.NullPointerException
        at org.apache.openjpa.enhance.PCRegistry.register(PCRegistry.java:210)
        at org.apache.openjpa.persistence.jdbc.maps.m2mmapex3.FullName.<clinit>(FullName.java)
        ... 38 more

        Rick Curtis added a comment -

        Reopening this issue as I think this might be causing a failure on Jenkins[1].

        [1] https://builds.apache.org/job/OpenJPA-trunk-deploy/org.apache.openjpa$openjpa-persistence-jdbc/200/consoleText

        Michael Dick added a comment -

        The patch looks good, thanks Jacob.

        Jacob Nowosatka added a comment -

        Patch changes the references to EMF's to weak references.

        Rick Curtis added a comment -

        Jake - Do you have a patch to fix this issue?


          People

          • Assignee:
            Rick Curtis
            Reporter:
            Jacob Nowosatka
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development