Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: build / infrastructure
    • Labels:
      None

      Description

      Currently used DBCP 1.2.2 implements JDBC 3 only, so using any of JDBC 4 methods will fail. DBCP 1.4 implements JDBC 4. A downside is that JDK 5 users wil not be able to use openjpa-all.jar with connection pooling enabled.

      http://openjpa.208410.n2.nabble.com/Commons-DBCP-upgrade-to-1-4-td5523026.html#a5523026

        Activity

        Milosz Tylenda created issue -
        Milosz Tylenda made changes -
        Field Original Value New Value
        Priority Major [ 3 ] Minor [ 4 ]
        Description Currently used DBCP 1.2.2 implements JDBC 3 only, so using any of JDBC 4 methods will fail. DBCP 1.4 implements JDBC 4. A downside is that JDK 5 users wil not be able to use openjpa-all.jar with connection pooling enabled.

        http://openjpa.208410.n2.nabble.com/Commons-DBCP-upgrade-to-1-4-td5523026.html#a5523026
        Component/s build / infrastructure [ 12311640 ]
        Milosz Tylenda made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Fix Version/s 2.1.0 [ 12314542 ]
        Resolution Fixed [ 1 ]
        Michael Dick added a comment -

        Closing issue which has been resolved for some time. If you believe the issue is not resolved please reopen or open a new issue.

        Michael Dick made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        22h 46m 1 Milosz Tylenda 02/Oct/10 19:35
        Resolved Resolved Closed Closed
        102d 22h 10m 1 Michael Dick 13/Jan/11 16:45

          People

          • Assignee:
            Milosz Tylenda
            Reporter:
            Milosz Tylenda
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development