OpenJPA
  1. OpenJPA
  2. OPENJPA-1441

NPE when enhancing a Serializable, versioned class

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.2, 1.3.0, 2.0.0-beta
    • Fix Version/s: 1.2.2, 1.3.0, 2.0.0-beta
    • Component/s: kernel
    • Labels:
      None

      Description

      I'm unable to enhance a Serializable class that has a version field when I have the DetachState property set as follows: openjpa.DetachState=fgs(DetachedStateField=true).

      The exception I'm seeing is :


      null
      Exception in thread "main" <openjpa-2.0.0-SNAPSHOT-r422266:890859 nonfatal general error> org.apache.openjpa.util.GeneralException: An error occurred while enhancing com.test.acme.annuity.common.bean.jpa.AbstractPersistebleObject. Exception message: null
      at org.apache.openjpa.enhance.PCEnhancer.run(PCEnhancer.java:545)
      at org.apache.openjpa.enhance.PCEnhancer.run(PCEnhancer.java:4652)
      at org.apache.openjpa.enhance.PCEnhancer.run(PCEnhancer.java:4594)
      at main.EnhancerDriver.main(EnhancerDriver.java:19)
      Caused by: java.lang.NullPointerException
      at org.apache.openjpa.enhance.PCEnhancer.addGetManagedValueCode(PCEnhancer.java:4320)
      at org.apache.openjpa.enhance.PCEnhancer.addGetManagedValueCode(PCEnhancer.java:4278)
      at org.apache.openjpa.enhance.PCEnhancer.writeExternal(PCEnhancer.java:4266)
      at org.apache.openjpa.enhance.PCEnhancer.addWriteExternal(PCEnhancer.java:4203)
      at org.apache.openjpa.enhance.PCEnhancer.addDetachExternalize(PCEnhancer.java:3991)
      at org.apache.openjpa.enhance.PCEnhancer.addAttachDetachCode(PCEnhancer.java:3761)
      at org.apache.openjpa.enhance.PCEnhancer.run(PCEnhancer.java:532)
      ... 3 more


        Issue Links

          Activity

          aurelien leboulanger added a comment -

          Hello,

          I have the same issue with openjpa-2.4.0 (with tomEE 1.7.2)

          ```
          openjpa-2.4.0-nonfinal-1598334-r422266:1599166 nonfatal general error> org.apache.openjpa.util.GeneralException: An error occurred while enhancing com.dsi.entities.Widget. Exception message: null
          at org.apache.openjpa.enhance.PCEnhancer.run(PCEnhancer.java:578)
          at org.apache.openjpa.enhance.PCClassFileTransformer.transform0(PCClassFileTransformer.java:153)
          at org.apache.openjpa.enhance.PCClassFileTransformer.transform(PCClassFileTransformer.java:126)
          at org.apache.openjpa.persistence.PersistenceProviderImpl$ClassTransformerImpl.transform(PersistenceProviderImpl.java:291)
          at org.apache.openejb.persistence.PersistenceUnitInfoImpl$PersistenceClassFileTransformer.transform(PersistenceUnitInfoImpl.java:356)
          at sun.instrument.TransformerManager.transform(TransformerManager.java:188)
          at sun.instrument.InstrumentationImpl.transform(InstrumentationImpl.java:428)
          at java.lang.ClassLoader.defineClass1(Native Method)
          at java.lang.ClassLoader.defineClass(ClassLoader.java:760)
          at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
          at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2957)
          at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1210)
          at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1690)
          at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1571)
          at org.apache.tomee.catalina.LazyStopWebappClassLoader.loadClass(LazyStopWebappClassLoader.java:129)
          at org.hibernate.internal.util.ReflectHelper.classForName(ReflectHelper.java:187)
          at org.hibernate.ejb.packaging.NativeScanner.getClassesInJar(NativeScanner.java:136)
          at org.hibernate.ejb.Ejb3Configuration.addScannedEntries(Ejb3Configuration.java:485)
          at org.hibernate.ejb.Ejb3Configuration.scanForClasses(Ejb3Configuration.java:852)
          at org.hibernate.ejb.Ejb3Configuration.configure(Ejb3Configuration.java:597)
          at org.hibernate.ejb.HibernatePersistence.createContainerEntityManagerFactory(HibernatePersistence.java:73)
          at org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean.createNativeEntityManagerFactory(LocalContainerEntityManagerFactoryBean.java:287)
          at org.springframework.orm.jpa.AbstractEntityManagerFactoryBean.afterPropertiesSet(AbstractEntityManagerFactoryBean.java:310)
          at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1514)
          at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1452)
          at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:519)
          at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:456)
          at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:294)
          at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:225)
          at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:291)
          at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:193)
          at org.springframework.context.support.AbstractApplicationContext.getBean(AbstractApplicationContext.java:1105)
          at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:915)
          at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:472)
          at org.springframework.web.context.ContextLoader.configureAndRefreshWebApplicationContext(ContextLoader.java:383)
          at org.springframework.web.context.ContextLoader.initWebApplicationContext(ContextLoader.java:283)
          at org.springframework.web.context.ContextLoaderListener.contextInitialized(ContextLoaderListener.java:111)
          at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4992)
          at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5490)
          at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
          at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:901)
          at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
          at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:649)
          at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:1083)
          at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:553)
          at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1671)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
          at java.lang.reflect.Method.invoke(Method.java:483)
          at org.apache.tomcat.util.modeler.BaseModelMBean.invoke(BaseModelMBean.java:301)
          at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultMBeanServerInterceptor.java:819)
          at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:801)
          at org.apache.catalina.manager.ManagerServlet.check(ManagerServlet.java:1485)
          at org.apache.catalina.manager.HTMLManagerServlet.upload(HTMLManagerServlet.java:286)
          at org.apache.catalina.manager.HTMLManagerServlet.doPost(HTMLManagerServlet.java:206)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:646)
          at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:303)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
          at org.apache.catalina.filters.CsrfPreventionFilter.doFilter(CsrfPreventionFilter.java:213)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
          at org.apache.tomcat.websocket.server.WsFilter.doFilter(WsFilter.java:52)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
          at org.apache.catalina.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:108)
          at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241)
          at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208)
          at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:220)
          at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122)
          at org.apache.tomee.catalina.OpenEJBValve.invoke(OpenEJBValve.java:44)
          at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:610)
          at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:171)
          at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
          at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950)
          at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116)
          at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:408)
          at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1070)
          at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611)
          at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:314)
          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
          at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
          at java.lang.Thread.run(Thread.java:745)
          Caused by: java.lang.NullPointerException
          at org.apache.openjpa.enhance.PCEnhancer.getfield(PCEnhancer.java:4052)
          at org.apache.openjpa.enhance.PCEnhancer.addGetManagedValueCode(PCEnhancer.java:4543)
          at org.apache.openjpa.enhance.PCEnhancer.addGetManagedValueCode(PCEnhancer.java:4519)
          at org.apache.openjpa.enhance.PCEnhancer.addProvideFieldsMethods(PCEnhancer.java:1379)
          at org.apache.openjpa.enhance.PCEnhancer.addPCMethods(PCEnhancer.java:1155)
          at org.apache.openjpa.enhance.PCEnhancer.run(PCEnhancer.java:566)
          ... 84 more
          ```

          Xiaoqin Feng added a comment -

          I am on vacation from 12/20/2009  to 12/26/2009.

          If you have any question on deployment and JEE bugs, please contact Saurabh Arora or my manager Maruthi Nuthikattu.

          For emergency, contact me at 925-209-5517.

          Xiaoqin Feng added a comment -

          I am on vacation from 12/20/2009  to 12/26/2009.

          If you have any question on deployment and JEE bugs, please contact Saurabh Arora or my manager Maruthi Nuthikattu.

          For emergency, contact me at 925-209-5517.

          Xiaoqin Feng added a comment -

          I am on vacation from 12/20/2009  to 12/26/2009.

          If you have any question on deployment and JEE bugs, please contact Saurabh Arora or my manager Maruthi Nuthikattu.

          For emergency, contact me at 925-209-5517.

          Xiaoqin Feng added a comment -

          I am on vacation from 12/20/2009  to 12/26/2009.

          If you have any question on deployment and JEE bugs, please contact Saurabh Arora or my manager Maruthi Nuthikattu.

          For emergency, contact me at 925-209-5517.

          Rick Curtis added a comment -

          Committed changes to 1.3.x and trunk.

          Rick Curtis added a comment -

          Attaching a patch for the 1.2.x branch.

          Rick Curtis added a comment -

          OPENJPA-1400 introduced this bug.


            People

            • Assignee:
              Rick Curtis
              Reporter:
              Rick Curtis
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development