OpenEJB
  1. OpenEJB
  2. OPENEJB-1994

App directory with space in name fails on Win platforms

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.7.0
    • Component/s: None
    • Labels:
      None
    • Environment:
      Win platforms

      Description

      Jars placed in an application deployment directory with space in the directory name fails on Win platforms

        Activity

        Andy Gumbrecht added a comment -

        Close issues in preparation for OpenEJB 4.7.0

        Andy Gumbrecht added a comment -

        Escaping issue addressed.
        Undeployment file locking issue located and fixed.

        Andy Gumbrecht added a comment -

        Added in progress fix in trunk.
        There is still a file lock issue on un-deployment.

        Andy Gumbrecht added a comment -

        Path spaces are being URL escaped with '%20', but should be unescaped before use.

        Jar not loaded. D:\App\unreleased built SK - 28.01.2013\Novus\storage\deployer\replaced.storage.deploy.openejb.jar. Unable to determine module type for jar: file:/D:/App/unreleased%20build%20SK%20-%2028.01.2013/Novus/storage/deployer/replaced.storage.deploy.openejb.jar: Unknown module type: url=/D:/App/unreleased%20build%20SK%20-%2028.01.2013/Novus/storage/deployer/replaced.storage.deploy.openejb.jar
        org.apache.openejb.config.UnknownModuleTypeException: Unable to determine module type for jar: file:/D:/App/unreleased%20build%20SK%20-%2028.01.2013/Novus/storage/deployer/replaced.storage.deploy.openejb.jar: Unknown module type: url=/D:/App/unreleased%20build%20SK%20-%2028.01.2013/Novus/storage/deployer/replaced.storage.deploy.openejb.jar
        at org.apache.openejb.config.DeploymentLoader.load(DeploymentLoader.java:130)
        at org.apache.openejb.config.ConfigurationFactory.configureApplication(ConfigurationFactory.java:725)
        at org.apache.openejb.config.ConfigurationFactory.getOpenEjbConfiguration(ConfigurationFactory.java:485)
        at org.apache.openejb.assembler.classic.Assembler.getOpenEjbConfiguration(Assembler.java:374)
        at org.apache.openejb.assembler.classic.Assembler.build(Assembler.java:353)
        at org.apache.openejb.OpenEJB$Instance.<init>(OpenEJB.java:147)
        at org.apache.openejb.OpenEJB$Instance.<init>(OpenEJB.java:65)
        at org.apache.openejb.OpenEJB.init(OpenEJB.java:292)
        at org.apache.openejb.OpenEJB.init(OpenEJB.java:272)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at org.apache.openejb.loader.OpenEJBInstance.init(OpenEJBInstance.java:36)
        at org.apache.openejb.core.LocalInitialContextFactory.init(LocalInitialContextFactory.java:69)
        at org.apache.openejb.core.LocalInitialContextFactory.init(LocalInitialContextFactory.java:51)
        at org.apache.openejb.core.LocalInitialContextFactory.getInitialContext(LocalInitialContextFactory.java:40)
        at javax.naming.spi.NamingManager.getInitialContext(NamingManager.java:667)
        at javax.naming.InitialContext.getDefaultInitCtx(InitialContext.java:288)
        at javax.naming.InitialContext.init(InitialContext.java:223)
        at javax.naming.InitialContext.<init>(InitialContext.java:197)
        at replaced.storage.local.Session.getInitialContext(Session.java:228)
        at replaced.storage.api.SessionFactory.seedLocalContext(SessionFactory.java:537)
        at replaced.storage.api.SessionFactory.getContextLocal(SessionFactory.java:460)
        at replaced.registry.storage.auth.Authenticator$1.run(Authenticator.java:100)
        at replaced.registry.ExecutorsIF$DefaultExecutors$1.run(ExecutorsIF.java:179)
        at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
        at java.lang.Thread.run(Thread.java:662)
        Caused by: org.apache.openejb.config.UnknownModuleTypeException: Unknown module type: url=/D:/App/unreleased%20build%20SK%20-%2028.01.2013/Novus/storage/deployer/replaced.storage.deploy.openejb.jar
        at org.apache.openejb.config.DeploymentLoader.discoverModuleType(DeploymentLoader.java:1643)
        at org.apache.openejb.config.DeploymentLoader.discoverModuleType(DeploymentLoader.java:1547)
        at org.apache.openejb.config.DeploymentLoader.load(DeploymentLoader.java:128)
        ... 28 more


          People

          • Assignee:
            Andy Gumbrecht
            Reporter:
            Andy Gumbrecht
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development