OpenEJB
  1. OpenEJB
  2. OPENEJB-1718

Package conflict with OSGI bundles openejb-core and openejb-client - org.apache.openejb.client

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Major Major
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The bundles openejb-core and openejb-client exports the same package org.apache.openejb.client. When a third party (using Dynamic-Import) tries to find the package it loads it from openejb-core and not from openejb-client

      Error :

      2011-12-07 18:19:05,888 | ERROR | ejb | TimerConsumer | ache.camel.processor.CamelLogger 232 | 188 - org.apache.camel.camel-core - 2.8.3 | Error processing exchange. Exchange[Message: OpenEJB-Remote]. Caused by: [java.lang.IllegalArgumentException - interface org.apache.openejb.client.EJBObjectProxy is not visible from class loader]
      java.lang.IllegalArgumentException: interface org.apache.openejb.client.EJBObjectProxy is not visible from class loader

      We can solve temporarily the problem by adding this in the camel test route

      org.apache.openejb.client;bundle-version="[4.0,5.0)",
      org.apache.openejb.core;bundle-version="[4.0,5.0)"

      and add DynamicImport-Package in camel-core

      but that creates dependencies with camel projects

      Solution : Rename the package org.apache.openejb.client in openejb-core

        Activity

          People

          • Assignee:
            Unassigned
            Reporter:
            Charles Moulliard
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:

              Development