Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 4.0.0-beta-2
    • Fix Version/s: 4.0.0-beta-2
    • Component/s: container system
    • Labels:
      None
    • Environment:
      Windows

      Description

      Hello everybody,

      I tried to inject a bean from a jar into a servlet within my web archive. The AnnotationDeployer fails to load the classes (within public EjbModule deploy(EjbModule ejbModule)) from the jar because of a small bug in the xbean-finder (see my other ticket: https://issues.apache.org/jira/browse/XBEAN-193 ) . I receive a unsatisfied dependency exception as a result during the deployment process. I fixed this issue in the xbean implementation and it works like a charm now.

      I attached a patch which handles this issue on the openejb side for the mean time.

      Best regards,
      Mart Köhler

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        67d 56m 1 David Blevins 23/Jan/12 11:06
        David Blevins made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Show
        David Blevins added a comment - 2011-11-17 - http://svn.apache.org/viewvc?view=revision&revision=1203150 - rmannibucau 2011-11-17 - http://svn.apache.org/viewvc?view=revision&revision=1203159 - rmannibucau
        David Blevins made changes -
        Fix Version/s 4.0.0-beta-2 [ 12318444 ]
        Show
        David Blevins added a comment - 2011-11-17 - http://svn.apache.org/viewvc?view=revision&revision=1203150 - rmannibucau 2011-11-17 - http://svn.apache.org/viewvc?view=revision&revision=1203159 - rmannibucau
        Mart Köhler made changes -
        Description Hello everybody,

        I tried to inject a bean from a jar into a servlet within my web archive. The AnnotationDeployer fails to load the classes (within public EjbModule deploy(EjbModule ejbModule)) from the jar because of a small bug in the xbean-finder (see my other ticket: https://issues.apache.org/jira/browse/XBEAN-193) . I receive a unsatisfied dependency exception as a result during the deployment process. I fixed this issue in the xbean implementation and it works like a charm now.

        I attached a patch which handles this issue on the openejb side for the mean time.

        Best regards,
        Mart Köhler

        Hello everybody,

        I tried to inject a bean from a jar into a servlet within my web archive. The AnnotationDeployer fails to load the classes (within public EjbModule deploy(EjbModule ejbModule)) from the jar because of a small bug in the xbean-finder (see my other ticket: https://issues.apache.org/jira/browse/XBEAN-193 ) . I receive a unsatisfied dependency exception as a result during the deployment process. I fixed this issue in the xbean implementation and it works like a charm now.

        I attached a patch which handles this issue on the openejb side for the mean time.

        Best regards,
        Mart Köhler

        Mart Köhler made changes -
        Field Original Value New Value
        Attachment post_processing_xbean_separator_issue.patch [ 12504051 ]
        Hide
        Mart Köhler added a comment -

        attached the patch

        Show
        Mart Köhler added a comment - attached the patch
        Mart Köhler created issue -

          People

          • Assignee:
            Unassigned
            Reporter:
            Mart Köhler
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development