OpenEJB
  1. OpenEJB
  2. OPENEJB-1261

JSP Error on installer-view.jsp with Tomcat 6.0.26

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.1.3
    • Fix Version/s: 3.1.3
    • Component/s: tomee
    • Labels:
      None
    • Environment:
      Tomcat 6.0.26, Ubuntu Linux. Java 1.6.x

      OpenEJB => trunk

      Description

      I checked out the trunk and was able to run the build.

      Deploying the "openejb.war" to Tomcat works fine, but launching the "install" gives me this JSP error:

      org.apache.jasper.JasperException: Unable to compile class for JSP:

      An error occurred at line: 98 in the jsp file: /installer-view.jsp
      installer.messages cannot be resolved or is not a field
      95: <img border='0' height='3' width='360' src='images/line_light.gif'><br>
      96: <table width='360' cellspacing='4' cellpadding='4' border='0'>
      97: <%
      98: for (String info : installer.messages.getInfos())

      { 99: %> 100: <tr> 101: <td><font size='2'><%= info %></font></td> An error occurred at line: 116 in the jsp file: /installer-view.jsp installer.messages cannot be resolved or is not a field 113: <% 114: }

      else {
      115: List<String> errors = new ArrayList<String>(paths.getErrors());
      116: errors.addAll(installer.messages.getErrors());
      117: if (!errors.isEmpty()) {
      118: %> Installation Failed<br><br>
      119: <FONT SIZE='2'>

      Stacktrace:
      org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:92)
      org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:330)
      org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:439)
      org.apache.jasper.compiler.Compiler.compile(Compiler.java:349)
      org.apache.jasper.compiler.Compiler.compile(Compiler.java:327)
      org.apache.jasper.compiler.Compiler.compile(Compiler.java:314)
      org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:589)
      org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:317)
      org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:313)
      org.apache.jasper.servlet.JspServlet.service(JspServlet.java:260)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
      org.apache.openejb.tomcat.installer.InstallerServlet.doIt(InstallerServlet.java:91)
      org.apache.openejb.tomcat.installer.InstallerServlet.doGet(InstallerServlet.java:58)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:617)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:717)

      note The full stack trace of the root cause is available in the Apache Tomcat/6.0.26 logs.

      1. installer-view.diff
        1 kB
        Matthias Weßendorf

        Activity

        Jean-Louis MONTEIRO added a comment -

        Fixed

        Matthias Weßendorf added a comment -

        hrm,

        on Tomcat 7.02 (beta) and openejb 3.2 I do still get it.

        I used the WAR (SNAPSHOT) from here:
        https://repository.apache.org/content/repositories/snapshots/org/apache/openejb/openejb-webapp/3.2-SNAPSHOT/

        Matthias Weßendorf added a comment -

        looks like the duplicate resources cause issues.
        the modified installer-view.jsp did not have the getAlerts() call.

        The one from REV 940423:
        http://svn.apache.org/viewcvs?view=rev&rev=940423

        does have it....


          People

          • Assignee:
            Jean-Louis MONTEIRO
            Reporter:
            Matthias Weßendorf
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development