Oozie
  1. Oozie
  2. OOZIE-813

Sub-workflow child job does not get group name even if parent carries it

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.2.0
    • Fix Version/s: 3.2.0
    • Component/s: None
    • Labels:

      Description

      Subworkflow AE needs to account for assigning group/acl name to child wf if parent has it. <propagate-configuration> should not be needed for something as basic as group/acl name.

      Example output:

      sub workflow child workflow job does not have the group name.

      $ oozie jobs -len 2
      Job ID App Name Status User Group Started Ended
      -----------------------------------------------------------------------------------------------------------
      0002-oozie-oozi-W child-wf KILLED joe - 2012-03-30 21:28 2012-03-30 21:31
      -----------------------------------------------------------------------------------------------------------
      0001-oozie-oozi-W parent-wf KILLED joe users 2012-03-30 21:28 2012-03-30 21:31

        Activity

          People

          • Assignee:
            Mona Chitnis
            Reporter:
            Mona Chitnis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2h
              2h
              Remaining:
              Remaining Estimate - 2h
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development