Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-3235

Upgrade ActiveMQ to 5.15.3

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 5.1.0
    • Fix Version/s: 5.1.0
    • Component/s: client
    • Labels:
      None

      Description

      An old, and vulnerable version of ActiveMQ is used by Oozie's tests (5.13.3).
      It seems that the jars are even included in the oozie-client with "compile" scope, but we only use them in unit tests.

      Oozie-client uses the JMS-API only from these jars, which could be included separately (javax.jms).

      The version could be upgraded to 5.14.2 and the scope changed to "test" instead of "compile".

        Attachments

        1. OOZIE-3235-002.patch
          1 kB
          Mate Juhasz
        2. OOZIE-3235-001.patch
          1 kB
          Mate Juhasz

          Activity

            People

            • Assignee:
              matijhs Mate Juhasz
              Reporter:
              matijhs Mate Juhasz
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: