Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-3172

Upgrade non-transitive Jackson dependencies from org.codehaus.jackson to com.fasterxml.jackson

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 5.0.0b1
    • Fix Version/s: 5.0.0
    • Component/s: core
    • Labels:
      None

      Description

      Jackson 1.9.3 is way too old, and has several security vulnerabilities as well. Jackson 2.9.2 covers most of these.

      Let's switch from org.codehaus.jackson to com.fasterxml.jackson in Oozie's direct (non-transitive) dependencies.

        Attachments

        1. OOZIE-3172.003.patch
          17 kB
          Andras Piros
        2. OOZIE-3172.002.patch
          17 kB
          Andras Piros
        3. OOZIE-3172.001.patch
          17 kB
          Andras Piros

          Issue Links

            Activity

              People

              • Assignee:
                andras.piros Andras Piros
                Reporter:
                andras.piros Andras Piros
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: