Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-3155

[ui] Job DAG is not refreshed when a job is finished

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: trunk, 5.0.0b1
    • Fix Version/s: 5.1.0
    • Component/s: client
    • Labels:
      None

      Description

      When opening a Job DAG when the job is still in progress, the DAG is OK, but when the job will finish, this diagram is not refreshed.

      Steps to reproduce:

      • submit a workflow (e.g. the subwf from the examples) - the wf should not end very quickly, to have time to catch it when it is still running
      • check the Job DAG when the job is still running
      • wait for the job to finish
      • check again the Job DAG -> is the same with the running one

      Note: if check it in a new tab, is OK, and also a browser refresh will solve it.

        Attachments

        1. Screen Shot 2018-01-10 at 16.23.28.png
          329 kB
          Julia Kinga Marton
        2. OOZIE-3155-1.patch
          3 kB
          Andras Salamon

          Issue Links

            Activity

              People

              • Assignee:
                asalamon74 Andras Salamon
                Reporter:
                kmarton Julia Kinga Marton
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: