Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-1961

Remove requireJavaVersion from enforcer rules

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.1.0
    • Component/s: None
    • Labels:
      None

      Description

      Currently the Oozie build fails with Java 1.7 due to this enforcer rule in pom.xml:

      <requireJavaVersion>
        <version>[${javaVersion}.0,${javaVersion}.1000}]</version>
      </requireJavaVersion>
      

      And javaVersion is set to 1.6.

      Maybe I'm missing something but I don't see why Oozie wouldn't compile/work with 1.7 or 1.8. This patch just removes this enforcer rule.

        Attachments

        1. OOZIE-1961.1.patch
          2 kB
          Lars Francke
        2. OOZIE-1961.2.patch
          2 kB
          Lars Francke
        3. OOZIE-1961.3.patch
          2 kB
          Lars Francke

          Activity

            People

            • Assignee:
              larsfrancke Lars Francke
              Reporter:
              larsfrancke Lars Francke

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment