Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-1681

Sqoop sharelib has no hsqldb jar version

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 4.1.0
    • Component/s: None
    • Labels:
      None

      Description

      In OOZIE-1343 hsqldb dependency was added to sqoop sharelib, but without version.
      Because of this maven will include hsqldb-1.8.0.7 which is used by oozie. This is wrong because sqoop itself uses hsqldb-1.8.0.10.

      So we have to define version for hsqldb as 1.8.0.10.

        Attachments

        1. OOZIE-1681.patch
          0.6 kB
          Ostap
        2. OOZIE-1681.2.patch
          0.5 kB
          Ostap

          Activity

            People

            • Assignee:
              omaliuvanchuk Ostap
              Reporter:
              omaliuvanchuk Ostap
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: