Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-1655

Change oozie.service.JPAService.validate.db.connection to true

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.3.2, 4.0.0
    • Fix Version/s: 4.1.0
    • Component/s: core
    • Labels:
      None

      Description

      We've seen many database-related issues solved by simply setting oozie.service.JPAService.validate.db.connection to true (default is false). My understanding of this property is that it makes sure that the database is properly connected, which is helpful when the connection isn't so good; and it only adds a minor overhead.

      It would be useful to change the default for this property to be true

      While we're at it, we should change oozie.service.JPAService.create.db.schema in oozie-default to false because its false in oozie-site and its a little confusing that they're not the same.

        Attachments

        1. OOZIE-1655.patch
          2 kB
          Robert Kanter
        2. OOZIE-1655.patch
          2 kB
          Robert Kanter

          Issue Links

            Activity

              People

              • Assignee:
                rkanter Robert Kanter
                Reporter:
                rkanter Robert Kanter
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: