Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-1634

TestJavaActionExecutor#testUpdateConfForUberMode fails against Hadoop 2

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: trunk
    • Fix Version/s: 4.1.0
    • Component/s: tests
    • Labels:
      None

      Description

      TestJavaActionExecutor#testUpdateConfForUberMode fails against Hadoop 2.

      It looks like the problem is that yarn.app.mapreduce.am.command-opts has a default value of -Xmx1024m in Hadoop 2 but (obviously) not in Hadoop 1. So, when the test is verifying the value of yarn.app.mapreduce.am.command-opts after some code appends values to it, it now includes -Xmx1024m when run against Hadoop 2 but not when run against Hadoop 1; and so the test fails.

        Attachments

        1. OOZIE-1634.patch
          1 kB
          Robert Kanter

          Issue Links

            Activity

              People

              • Assignee:
                rkanter Robert Kanter
                Reporter:
                rkanter Robert Kanter
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: