Oozie
  1. Oozie
  2. OOZIE-1088

currently, oozie trunk use hadoop1.0.1, as for hadoop1.x, the stablest version of hadoop is 1.0.4.

    Details

    • Type: Improvement Improvement
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 3.2.0, 3.3.0, 3.2.1, trunk
    • Fix Version/s: None
    • Component/s: core

      Description

      currently, oozie trunk use hadoop1.0.1, as for hadoop1.x, the stablest version of hadoop is 1.0.4.
      for the oozie's stability, I think we had better upgrade oozie's hadoop from 1.0.1 to 1.0.4

        Issue Links

          Activity

          zhu jin wei added a comment -

          jinwei zhu zhujinwei09@gmail.com

          Dear oozie community,
          I found the oozie truck has used hadoop1.0.1, but the stablest version of hadoop is hadoop1.0.3 . So, Why you use low vesion but not the stablest version ?
          I want to contribute some codes back , and my oozie is using hadoop1.0.3. I have also tried to use hadoop1.0.3 on your oozie trunk, all the UT passed. So, will you upgrade oozie trunk and other oozie branch from using hadoop1.0.1 to using hadoop1.0.3? If yes, what is your upgrade plan ?

          Best Regards!
          ---------------------------------------------------------------------------------------------------------------------------------------------------

          Roman Shaposhnik rvs@apache.org

          On Sun, Nov 25, 2012 at 9:37 PM, jinwei zhu <zhujinwei09@gmail.com> wrote:
          > Dear oozie community,
          > I found the oozie truck has used hadoop1.0.1, but the stablest
          > version of hadoop is hadoop1.0.3 . So, Why you use low vesion but not the
          > stablest version ?

          I'm not sure where this is coming from, but there's also Hadoop 1.1.0

          > I want to contribute some codes back , and my oozie is using
          > hadoop1.0.3. I have also tried to use hadoop1.0.3 on your oozie trunk,
          > all the UT passed. So, will you upgrade oozie trunk and other oozie branch
          > from using hadoop1.0.1 to using hadoop1.0.3? If yes, what is your upgrade
          > plan ?

          Personally I'd suggest bumping it to Hadoop 1.1.0

          Thanks,
          Roman.

          -------------------------------------------------------------------------------------------------
          Yu Li carp84@gmail.com

          Hi Roman,

          AFAIK, 1.1.0 is a beta release, and the most recent stable release is
          1.0.4, and I think it more reasonable to use a stable version, what's your
          opinion?

          Some background on where the question comes from: we have successfully
          enabling oozie run on IBM JDK, and would like to contribute the changes
          back to community. However, while we testing the patch with original oozie
          branch, we find it still using hadoop-1.0.1, which misses HADOOP-6941(Adds
          support for building Hadoop with IBM's JDK), thus would have compile/UT
          error in IBM JDK. We also executed UT after changing the hadoop version to
          1.0.4 in pom.xml and confirmed all UT could pass w/o error, so we wonder
          whether community would consider upgrade the hadoop version it specifies in
          the pom.xml.

          Looking forward to your reply, thanks!
          --------------------------------------------------------------------------------------------

          Harsh J added a comment -

          Dupe of OOZIE-816. Lets discuss there?

          zhu jin wei added a comment -

          ok. Actually, I have tested hadoop 1.0.4 , all the UT passed. Any way, I will upload my patch and the result after running test-patch.

          zhu jin wei added a comment -

          Testing patch ./patch

          WARNING: Running test-patch on a dirty local svn workspace

          ----------------------------

          +1 PATCH_APPLIES
          +1 CLEAN
          -1 RAW_PATCH_ANALYSIS
          . +1 the patch does not introduce any @author tags
          . +1 the patch does not introduce any tabs
          . +1 the patch does not introduce any trailing spaces
          . +1 the patch does not introduce any line longer than 132
          . -1 the patch does not add/modify any testcase
          -1 RAT
          . -1 the patch seems to introduce 119 new RAT warning(s)
          . WARNING: the current HEAD has 2235 RAT warning(s), they should be addressed ASAP
          +1 JAVADOC
          . +1 the patch does not seem to introduce new Javadoc warnings
          +1 COMPILE
          . +1 HEAD compiles
          . +1 patch compiles
          . +1 the patch does not seem to introduce new javac warnings
          +1 BACKWARDS_COMPATIBILITY
          . +1 the patch does not change any JPA Entity/Colum/Basic/Lob/Transient annotations
          . +1 the patch does not modify JPA files
          +1 TESTS
          . Tests run: 922
          +1 DISTRO
          . +1 distro tarball builds with the patch

          ----------------------------
          -1 Overall result, please check the reported -1(s)

          . There is at least one warning, please check

          Harsh J added a comment -

          Hi,

          I've moved your patch to OOZIE-816. Please continue work/discussion there as I've already marked this as duplicate. I've assigned OOZIE-816 to you.


            People

            • Assignee:
              Unassigned
              Reporter:
              zhu jin wei
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development