Oozie
  1. Oozie
  2. OOZIE-1078

Help -> Documentation and Help -> Online Help should link to oozie.apache.org/

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: trunk
    • Fix Version/s: 4.0.0
    • Component/s: workflow
    • Labels:

      Description

      Help -> Documentation and Help -> Online Help currently show an alert saying "to be implemented soon".

      They should link to a workflowgenerator's maven site, which does not exist in a public place (not even jenkins' precommit job's workspace)

      The ideal place is somewhere under http://oozie.apache.org/docs/ once it is generated, but it can at least link to the oozie top page.

      1. help_link_opens_new_tab.png
        44 kB
        jun aoki
      2. help_menu_alert.png
        61 kB
        jun aoki
      3. OOZIE-1078.patch
        1 kB
        jun aoki
      4. OOZIE-1078-2.patch
        2 kB
        jun aoki

        Activity

        jun aoki added a comment -

        alert screen shot attached

        jun aoki added a comment -
        Hadoop QA added a comment -

        Testing JIRA OOZIE-1078

        Cleaning local svn workspace

        ----------------------------

        -1 Patch failed to apply to head of branch

        ----------------------------

        jun aoki added a comment -

        Canceled my patch. Maybe something wrong with my diff. (the previous diff had svn:ignore. Does it cause some problem?)
        I'm re-submitting a patch.

        jun aoki added a comment -
        jun aoki added a comment -

        I'm attaching the same patch here.

        Hadoop QA added a comment -

        Testing JIRA OOZIE-1078

        Cleaning local svn workspace

        ----------------------------

        -1 Patch failed to apply to head of branch

        ----------------------------

        jun aoki added a comment -

        The patch is being taken from the oozie top folder.

        Hadoop QA added a comment -

        Testing JIRA OOZIE-1078

        Cleaning local svn workspace

        ----------------------------

        +1 PATCH_APPLIES
        +1 CLEAN
        -1 RAW_PATCH_ANALYSIS
        . +1 the patch does not introduce any @author tags
        . +1 the patch does not introduce any tabs
        . +1 the patch does not introduce any trailing spaces
        . +1 the patch does not introduce any line longer than 132
        . -1 the patch does not add/modify any testcase
        +1 RAT
        . +1 the patch does not seem to introduce new RAT warnings
        +1 JAVADOC
        . +1 the patch does not seem to introduce new Javadoc warnings
        +1 COMPILE
        . +1 HEAD compiles
        . +1 patch compiles
        . +1 the patch does not seem to introduce new javac warnings
        +1 BACKWARDS_COMPATIBILITY
        . +1 the patch does not change any JPA Entity/Colum/Basic/Lob/Transient annotations
        . +1 the patch does not modify JPA files
        +1 TESTS
        . Tests run: 920
        +1 DISTRO
        . +1 distro tarball builds with the patch

        ----------------------------
        -1 Overall result, please check the reported -1(s)

        The full output of the test-patch run is available at

        . https://builds.apache.org/job/oozie-trunk-precommit-build/197/

        Ryota Egashira added a comment -

        several comments.

        • on clicking doc/help, it's designed to open page in new tab, such that wfgen tab remains for usability. I found it works like this in Chrome, but not in Firefox (16.0.2), only me ?
        • when applied patch, I saw "Stripping trailing CRs from patch." probably it's because patch created in Windows, so should not be issue.
        • minor point, no need to open new ReviewBoard to change original patch, in original one, you can "Update Diff"
        jun aoki added a comment -

        Ryota, thank you for your comment. For Firefox I confirmed it opens a new tab on my environment. (FF version is 14.0.1)

        Hadoop QA added a comment -

        Testing JIRA OOZIE-1078

        Cleaning local svn workspace

        ----------------------------

        -1 Patch failed to apply to head of branch

        ----------------------------

        Ryota Egashira added a comment -

        Jun, thanks for double-check.
        +1 from me

        Mohammad Kamrul Islam added a comment -

        +1 committing

        jun aoki added a comment -

        It was committed by Mohammad. Mark this as Resolved.


          People

          • Assignee:
            jun aoki
            Reporter:
            jun aoki
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1h
              1h
              Remaining:
              Remaining Estimate - 1h
              1h
              Logged:
              Time Spent - Not Specified
              Not Specified

                Development