Uploaded image for project: 'Oozie'
  1. Oozie
  2. OOZIE-1006

Oozie fails to add required dependency for Hadoop 2.0.2

VotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.2.0
    • Fix Version/s: 3.3.0
    • Component/s: scripts
    • Labels:

      Description

      There are a few hadoop 2.0.2 dependency issues while bundling 'em into oozie war:

      • commons-cli isn't added which is required by DFSClient
      • hadoop-yarn-client isn't added which is required for launching jobs (this was a result of recent refactoring in yarn from 2.0.0 to 2.0.2)
      • avro-ipc is included that isn't required and not available in hadoop-client

      This patch adds commons-cli-.jar, hadoop-yarn-client${suffix}.jar and removes avro-ipc-.jar.

        Attachments

        1. OOZIE-1006.patch
          2 kB
          Venkatesh Seetharam

          Activity

            People

            • Assignee:
              svenkat Venkatesh Seetharam
              Reporter:
              svenkat Venkatesh Seetharam

              Dates

              • Created:
                Updated:
                Resolved:

                Issue deployment