Uploaded image for project: 'OODT'
  1. OODT
  2. OODT-640

Build warnings for maven-war-plugin version number for CAS-Product POM

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.6
    • Fix Version/s: 0.6
    • Component/s: product server
    • Labels:
    • Environment:

      Tested with Maven 2.2.1 and Maven 3.0.4.
      (Mac OSX 10.8 and also Lubuntu 13.04)
      (Latest Java 7 JDK)

    • Skill Level:
      Newcomer (Easy) - Everyone can do this

      Description

      When building CAS-Product with Maven 3, Maven complains about a missing version number for the maven-war-plugin.

      [WARNING]
      [WARNING] Some problems were encountered while building the effective model for org.apache.oodt:cas-product:war:0.6-SNAPSHOT
      [WARNING] 'build.plugins.plugin.version' for org.apache.maven.plugins:maven-war-plugin is missing. @ line 35, column 15
      [WARNING]
      [WARNING] It is highly recommended to fix these problems because they threaten the stability of your build.
      [WARNING]
      [WARNING] For this reason, future Maven versions might no longer support building such malformed projects.
      [WARNING]

      Later during the build it picks up the default version for the plugin:

      [INFO] — maven-war-plugin:2.1.1:war (default-war) @ cas-product —

      Explicitly stating this version number for the plugin in the POM, as shown below, clears the above warnings:

      pom.xml
      <plugin>
        <artifactId>maven-war-plugin</artifactId>
        <version>2.1.1</version>
        ...
      </plugin>
      

        Attachments

          Activity

            People

            • Assignee:
              rlaidlaw Ross Laidlaw
              Reporter:
              rlaidlaw Ross Laidlaw
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: