OODT
  1. OODT
  2. OODT-311

Test failing related to workflow tasks and the DataSourceWorkflowRepository

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.4
    • Component/s: workflow manager
    • Labels:
      None
    • Environment:

      0.4-SNAPSHOT

      Description

      As reported on the mailing list: http://s.apache.org/zIe and replicated by Chris A. Mattmann:

      [chipotle:~/src/oodt/trunk] mattmann% more workflow/target/surefire-reports/org.apache.oodt.cas.workflow.repository.TestWorkflowDataSourceRepository.txt 
      -------------------------------------------------------------------------------
      Test set: org.apache.oodt.cas.workflow.repository.TestWorkflowDataSourceRepository
      -------------------------------------------------------------------------------
      Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.38 sec <<< FAILURE!
      testWorkflowConditions(org.apache.oodt.cas.workflow.repository.TestWorkflowDataSourceRepository)  Time elapsed: 0.282 sec  <<< FAILURE!
      junit.framework.AssertionFailedError: Attempt to insert null into a non-nullable column: column: WORKFLOW_TASK_ID table: WORKFLOW_TASKS
              at junit.framework.Assert.fail(Assert.java:47)
              at org.apache.oodt.cas.workflow.repository.TestWorkflowDataSourceRepository.testWorkflowConditions(TestWorkflowDataSourceRepository.java:117)
      
      [chipotle:~/src/oodt/trunk] mattmann% more workflow/target/surefire-reports/org.apache.oodt.cas.workflow.repository.TestWorkflowDataSourceRepository-output.txt 
      java.sql.SQLException: Attempt to insert null into a non-nullable column: column: WORKFLOW_TASK_ID table: WORKFLOW_TASKS
              at org.hsqldb.jdbc.Util.sqlException(Unknown Source)
              at org.hsqldb.jdbc.jdbcStatement.fetchResult(Unknown Source)
              at org.hsqldb.jdbc.jdbcStatement.execute(Unknown Source)
              at org.apache.commons.dbcp.DelegatingStatement.execute(DelegatingStatement.java:261)
              at org.apache.oodt.cas.workflow.repository.DataSourceWorkflowRepository.commitTask(DataSourceWorkflowRepository.java:1393)
              at org.apache.oodt.cas.workflow.repository.DataSourceWorkflowRepository.getGlobalWorkflowConditionsTask(DataSourceWorkflowRepository.java:1587)
              at org.apache.oodt.cas.workflow.repository.DataSourceWorkflowRepository.handleGlobalWorkflowConditions(DataSourceWorkflowRepository.java:1572)
              at org.apache.oodt.cas.workflow.repository.DataSourceWorkflowRepository.getWorkflowById(DataSourceWorkflowRepository.java:195)
              at org.apache.oodt.cas.workflow.repository.DataSourceWorkflowRepository.getWorkflowById(DataSourceWorkflowRepository.java:165)
              at org.apache.oodt.cas.workflow.repository.TestWorkflowDataSourceRepository.testWorkflowConditions(TestWorkflowDataSourceRepository.java:114)
              at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
              at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
              at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      

      We're seeing a test error in the DataSourceWorkflowRepository. It appears since OODT-205.

        Issue Links

          Activity

          Rishi Verma added a comment -

          I can confirm the fix - now able to successfully build and test the latest WM. Thanks Chris!

          Chris A. Mattmann added a comment -
          • fix applied in r1160809 and in r1160814. This had to do with OODT-205. When the DataSourceWorkflowRepository detects global workflow conditions, it compiles a new WorkflowTask and assigns them those conditions. Even though the task is "virtual" it still must be persisted in the workflow repository. When the DataSourceWorkflowRepository was handling that in its commitTask method, it neglected to provide an ID field for the new task.

            People

            • Assignee:
              Chris A. Mattmann
              Reporter:
              Rishi Verma
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development