Uploaded image for project: 'OODT'
  1. OODT
  2. OODT-1009

Cannot Build OODT from source using JDK 10.x (Deprecated APIs)

    XMLWordPrintableJSON

Details

    • Bug
    • Status: Open
    • Major
    • Resolution: Unresolved
    • None
    • 2.0
    • None
    • None
    • Don't Know (Unsure) - The default level

    Description

      The oodt-commons module uses CORBA package, which is removed in JDK 10.x. To be compatible with JDK 10.x, need to remove the CORBA dependencies.

      The ExecServer is marked as deprecated, but it still has CORBA dependencies in it.

      Attachments

        Issue Links

          Activity

            People

              imesha Imesha Sudasingha
              yasithmilinda Yasith Jayawardana
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:

                Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0h
                  0h
                  Logged:
                  Time Spent - 20m
                  20m