Apache Onami
  1. Apache Onami
  2. ONAMI-78

Enable the sources.jar generation during SNAPSHOT builds

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: parent-3
    • Fix Version/s: parent-3
    • Component/s: parent
    • Labels:
      None

      Description

      I would be great to enable the generation of all test and source artifacts when building a snapshot (not only release).

      This has the advantages that these artifacts will be deployed to maven snapshot repositories (source resolved in ide) and than any module has access to test code (for mocks for example).

      1. ONAMI-78_working.patch
        4 kB
        Simone Tripodi
      2. ONAMI-78.patch
        6 kB
        Eric Charles

        Activity

        Hudson added a comment -

        Integrated in Onami-Parent #91 (See https://builds.apache.org/job/Onami-Parent/91/)
        ONAMI-78 Enable the sources.jar generation during SNAPSHOT builds (Revision 1446511)

        Result = SUCCESS
        eric :
        Files :

        • /incubator/onami/trunk/parent/pom.xml
        Eric Charles added a comment -
        Eric Charles added a comment -

        Hi Simone,
        Thx, it is working as expected.
        I think I have runned without changing the parent version (should have been be 3-incubator-SNAPSHOT, and not 2-incubator).
        I will rename this JIRA and commit the parent
        Thx ,Eric

        Simone Tripodi added a comment -

        Hi Eric,

        please have a look at ONAMI-78_working.patch, it makes stuff working on my machine ™ as desired.

        Can you give a try please, to verify it works also for you?

        This is my current environment:

        $ mvn --version
        Apache Maven 3.0.4 (r1232337; 2012-01-17 09:44:56+0100)
        Maven home: /Applications/apache-maven-3.0.4
        Java version: 1.6.0_37, vendor: Apple Inc.
        Java home: /System/Library/Java/JavaVirtualMachines/1.6.0.jdk/Contents/Home
        Default locale: en_US, platform encoding: MacRoman
        OS name: "mac os x", version: "10.8.2", arch: "x86_64", family: "mac"

        Simone Tripodi added a comment -

        salut mon ami,

        something strange happened, I didn't experience such pain - I'll try to give you a help by giving an experiment tonight.

        Eric Charles added a comment -

        Quick update:

        From the discussion on the mailing list, it sounds like we agree to generate the source-jar on SNAPSHOT (but not the test-jar, source-test-jar, javadoc).

        I have tried to define the maven-source-jar plugin in the parent (in build/plugins), but from my previous experience, confirmed by this one more test, it is not enough: maven-jar-plugin must also be defined (If I miss something, just tell me how I should do).

        Defining also maven-jar-plugin leads us to https://jira.codehaus.org/browse/MJAR-163 (I have opened it, will see the comments I can get there).

        Eric Charles added a comment -

        Attached the proposal with the impact on spi module.

        All other child module should add
        <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-jar-plugin</artifactId>
        </plugin>

        Eric Charles added a comment -

        Adding maven-source-plugin and tuning maven-jar-plugin in parent pom, I felt in the exact same issue described on
        http://markmail.org/message/mjsn2xozkcesethl

        The question posted on maven-users ml is unanswered.

        The error is:

        [ERROR] Failed to execute goal org.apache.maven.plugins:maven-jar-plugin:2.4:jar (jar) on project org.apache.onami.parent: Error assembling JAR: Manifest file: /Users/eric/wrk/osa/onami.svn/parent/target/osgi/MANIFEST.MF does not exist. -> [Help 1]

        I understand that maven-jar-plugin expects a osgi/MANIFEST which is not present because maven-bundel-plugin did not generate it (it is a module of type 'pom', without classes).

        As workaround, I move the maven-jar-plugin in the pluginManagement, as side effect that all childs must declare the maven-jar-plugin usage.


          People

          • Assignee:
            Eric Charles
            Reporter:
            Eric Charles
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development