Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: Trunk
    • Fix Version/s: Upcoming Release
    • Component/s: order
    • Labels:
      None

      Description

      Steps to regenerate:
      1. Open OrderView screen.
      2. Click on Edit Items under Actions section.
      3. Now you can see the new section "Add To Order" where FTL error is generating.

      1. OFBIZ-9803.patch
        0.8 kB
        Renuka Srishti

        Activity

        Renuka_Srishti Renuka Srishti added a comment -

        Here is the patch for this issue.

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks Renuka,

        I have no ideas why this happens now. It's not happening in R16 which is good and reassuring. So it's only a recently introduced regression. I hope there are no others impacts...

        Anyway your patch is in trunk at revision: 1811061

        Renuka_Srishti Renuka Srishti added a comment -

        Thanks Jacques,
        Yes, It is running in R16 because the shipGroups list coming as LinkedList, but in Trunk, this list is coming as ArrayList. That's why ".first" is not working in Trunk.
        I will explore why there is a difference in the class return.

        jacques.le.roux Jacques Le Roux added a comment -

        Thanks for your investigation Renuka


          People

          • Assignee:
            jacques.le.roux Jacques Le Roux
            Reporter:
            Renuka_Srishti Renuka Srishti
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development