Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Implemented
    • Affects Version/s: Trunk
    • Fix Version/s: Upcoming Release
    • Component/s: framework
    • Labels:
      None

      Description

      • AbstractEntityConditionCache.java:68, RCN_REDUNDANT_NULLCHECK_OF_NONNULL_VALUE
        RCN: Redundant nullcheck of model, which is known to be non-null in org.apache.ofbiz.entity.cache.AbstractEntityConditionCache.remove(GenericEntity)

      This method contains a redundant check of a known non-null value against the constant null.

      • AbstractEntityConditionCache.java:169, UCF_USELESS_CONTROL_FLOW
        UCF: Useless control flow in org.apache.ofbiz.entity.cache.AbstractEntityConditionCache.storeHook(boolean, GenericEntity, GenericEntity)

      This method contains a useless control flow statement, where control flow continues onto the same place regardless of whether or not the branch is taken. For example, this is caused by having an empty statement block for an if statement:

      if (argv.length == 0)

      { // TODO: handle this case }
      • AbstractEntityConditionCache.java:183, UCF_USELESS_CONTROL_FLOW
        UCF: Useless control flow in org.apache.ofbiz.entity.cache.AbstractEntityConditionCache.storeHook(String, boolean, List, List)

      This method contains a useless control flow statement, where control flow continues onto the same place regardless of whether or not the branch is taken. For example, this is caused by having an empty statement block for an if statement:

      if (argv.length == 0)

      { // TODO: handle this case }

        Activity

        Dennis Balkir Dennis Balkir added a comment -
        • Diamond Operators fixed
        • Line 68: removed the unnecessary if, model cannot be null at this point
        • Line 167: not used if phase removed
        • Line 181: not used if phrase removed
        mbrohl Michael Brohl added a comment -

        Thanks Dennis,

        your patch is in trunk r1813631.


          People

          • Assignee:
            mbrohl Michael Brohl
            Reporter:
            Dennis Balkir Dennis Balkir
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development