Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9410

Software not usable all standard installs failed

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 16.11.02
    • Fix Version/s: 16.11.03
    • Component/s: ALL COMPONENTS
    • Labels:
      None
    • Environment:

      Several Linux Versions all Java 1.8
      1.3 and 1.6 OFBiz

      Description

      Jun 15, 2017 8:50:03 AM org.apache.coyote.http11.AbstractHttp11Processor process
      INFO: Error parsing HTTP request header
       Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
      java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
      	at org.apache.coyote.http11.AbstractNioInputBuffer.parseRequestLine(AbstractNioInputBuffer.java:233)
      	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1017)
      	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:684)
      	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1519)
      	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1475)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
      	at java.lang.Thread.run(Thread.java:748)
      
      Jun 15, 2017 8:50:26 AM org.apache.coyote.http11.AbstractHttp11Processor process
      INFO: Error parsing HTTP request header
       Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
      java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
      	at org.apache.coyote.http11.AbstractNioInputBuffer.parseRequestLine(AbstractNioInputBuffer.java:233)
      	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1017)
      	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:684)
      	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1519)
      	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1475)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
      	at java.lang.Thread.run(Thread.java:748)
      
      Jun 15, 2017 8:50:50 AM org.apache.coyote.http11.AbstractHttp11Processor process
      INFO: Error parsing HTTP request header
       Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.
      java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens
      	at org.apache.coyote.http11.AbstractNioInputBuffer.parseRequestLine(AbstractNioInputBuffer.java:233)
      	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1017)
      	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:684)
      	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1519)
      	at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.run(NioEndpoint.java:1475)
      	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
      	at java.lang.Thread.run(Thread.java:748)
      
      1. OFBIZ-9410.patch
        3 kB
        Jacques Le Roux

        Issue Links

          Activity

          jacques.le.roux Jacques Le Roux added a comment - - edited

          Hi Scott, All,

          This was fixed with OFBIZ-8202, unfortunately 16.11.02 still contains this bug. So I'm sorry, you need to update your copy yourself. For that there are 2 means: either you

          • svn checkout the R16.11 branch and make an svn export to get rid of .svn
          • Apply a patch from r1798179 on your current copy
          jacques.le.roux Jacques Le Roux added a comment -

          I'm pretty sure this did not concern R13.07 so closing now. Please Scott reopen if you disagree, thanks.

          jacques.le.roux Jacques Le Roux added a comment -

          I reopen to clarify the status of R13.07

          jacques.le.roux Jacques Le Roux added a comment - - edited

          Hi Scott,

          I'm very sorry for this error in our 16.11.02 release, thank you for your report!

          This was in broken by OFBIZ-8202 with r1787949 and fixed in the same issue with r1798179, thank you Deepak!

          I think I missed to attach a patch for easier fix. I will do here and in OFBIZ-8202.

          Now I'm surprised that you encouter the same issue in R13.07. I guess it's another one, could you please check and report? Thanks!

          hansbak Hans Bakker added a comment -

          Thank you Scott, we always welcome new people to improve our product.

          provost Scott Provost added a comment -

          I will write a more tolerant testing script and attempt to independently verify for Debian 8 and Centos 7

          deepak.dixit Deepak Dixit added a comment -

          Hi Hans,

          EntityListIterator with no transaction error has been fix at http://svn.apache.org/viewvc?rev=1798179&view=rev

          scottprovost Scott Provost added a comment -

          No script was run. After 3 stack Traces in startup testing halted.

          On Fri, Jun 16, 2017 at 1:16 AM, Deepak Dixit (JIRA) <jira@apache.org>

          hansbak Hans Bakker added a comment -

          As I said, sure this problem needs to be solved, it looks like there is an error in the automatic extension of order subscriptions.

          However you can use the system even after three errors.

          Thank you for reporting!

          Regards,
          Hans

          deepak.dixit Deepak Dixit added a comment -

          >>It may reject after 3 stack traces
          Let me check for multiple hit using incorrect port.

          >>What does you automated testing system do?
          I am asking that are you using any automated script that access ofbiz?
          It might possible that it access ofbiz using incorrect url (https protocol with 8080 port)

          >> Should special instruction be added to the install instruction to ignore
          errors?
          There is an entry in README.md file

          ### Visit OFBiz through your browser:
          
          [Order Back Office](https://localhost:8443/ordermgr)
          
          [Accounting Back Office](https://localhost:8443/accounting)
          
          [Administrator interface](https://localhost:8443/webtools)
          
          You can log in with the user __admin__ and password __ofbiz__.
          
          
          scottprovost Scott Provost added a comment -

          It may reject after 3 stack traces. What does you automated testing system
          do?
          Should special instruction be added to the install instruction to ignore
          errors?

          On Fri, Jun 16, 2017 at 12:59 AM, Deepak Dixit (JIRA) <jira@apache.org>

          deepak.dixit Deepak Dixit added a comment -

          If we access application using https://localhost:8080/partymgr this way then Invalid character found error generated. But it does not stop application. I am able to reproduce it using above way.

          I saw your log file, data loaded successfully, server start normally and it went down suddenly.

          2017-06-15 11:08:02,209 |OFBiz-JobQueue-0     |ServiceDispatcher             |T| Sync service [default/cancelAllBackOrders] finished in [82] milliseconds
          2017-06-15 11:09:03,562 |Thread-0             |ContainerLoader               |I| Shutting down containers
          

          server was up for around one minute.
          Could you please cross check that your are not performing any tests or automated script is executing?

          Also http://utpe.org/log.txt does this complete log file?

          hansbak Hans Bakker added a comment - - edited

          Ok, i tried it, and i have the same error on screen which should sure be solved.

          HOWEVER

          the system is fully functional, so please open your browser and enter:
          https://localhost:8443/ordermgr

          Regards,
          Hans

          hansbak Hans Bakker added a comment -

          Ok is see, i was trying the trunk version which works fine, you have used the 16.11.02 version, let me try that.

          provost Scott Provost added a comment -

          I happen to know that is not true.
          All test are done with clean virtual machines with clean new installs.
          We have confirmed that the code is not installable in its current state.

          hansbak Hans Bakker added a comment -

          The problem is that i cannot reproduce the problem you have. Since it could be related to the performFind service with the iterator not closed, Jacques did some changes there.....so i leave it to up to him to shine some light on this....

          provost Scott Provost added a comment -

          As can be seen in the text log. It crashed before completion.
          It did not even start. On any of the systems.
          http://utpe.org/log.txt

          hansbak Hans Bakker added a comment -

          Ok Scott, more basic,

          you started the system on linux with:
          ./gradlew cleanAll loadAll`
          ./gradlew ofbiz`

          and waited until the system had started up: command line stops scrolling

          did you then opened the browser and inserted:
          https://localhost:8443/ordermgr
          as url?

          what kind of response you then got?

          provost Scott Provost added a comment -

          No. the software crashed during installation or startup on all systems.
          As far as we know it never opened a socket.

          scottprovost Scott Provost added a comment -

          Never got any version to install on any operating system.
          The start process never completed so there was no url to go to.

          On Thu, Jun 15, 2017 at 11:59 PM, Hans Bakker (JIRA) <jira@apache.org>

          hansbak Hans Bakker added a comment -

          just a question, did you start the browser with the url:
          https://localhost:8443/ordermgr

          and not:
          https://localhost:8080/ordermgr

          this could give you the header error

          Regards,
          Hans Bakker
          CEO antwebsystems.com

          provost Scott Provost added a comment -

          We attempt install following the published instruction on assorted versions of linux both stable and the version prior to the current stable version. The goal is to determine if there is genuine effort by the publishers to provide an installable and usable open source project.

          As an Apache project the maintainers must be doing test installs to verify and publish any limitation as to version of operating systems and prerequisites. Put simply, you must provide install instruction that work on whatever OS's you support and your stable code should run on at least one possible configuration.

          This software has been determined in violation of Apache minimum standards and indicating it is a usable package may bring liability on Apache Software foundation and the maintainers of this program. Thank you for helping us eliminate fake open source and defunct application.

          mbrohl Michael Brohl added a comment -

          Please give us at least a description what steps you did to reproduce the error, thanks.


            People

            • Assignee:
              jacques.le.roux Jacques Le Roux
              Reporter:
              provost Scott Provost
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development