Uploaded image for project: 'OFBiz'
  1. OFBiz
  2. OFBIZ-9224

16.11 ofbizUrl include host+port and break some reverse-proxy / docker setups

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: Release Branch 16.11
    • Fix Version/s: 16.11.02
    • Component/s: None
    • Labels:
      None

      Description

      OFBiz 16.11 has changed how it generates urls in its templates.
      It sometimes includes hostname+port.

      This can be reproduced on the official ofbiz-demo site:

      Go to http://ofbiz.apache.org/

      • Open the Ofbiz 13.07 Demo (Management Apps)
      • - it will auto-login for your, do a logout so that you can see the login-mask
      • - look at the HTML code and look for the form-post url etc. You can see that none of the URLs include hostname:port. They are all "/url/path"
      • Open the Ofbiz 16.11 Demo (Management Apps)
      • - it will auto-login for your, do a logout so that you can see the login-mask
      • - look at the HTML code and look for the form-post url etc.
      • - the post-urls and login-links have format: https://hostname:port/url/path

      The new 16.11 behaviour can cause problems in cluster / reverse-proxy setups where actual host:port does not match public host:port

      Before 16.11 this was not an issue because all links were without hostname:port. But now the login masks loads but the subsequent links all show the wrong port.

      url.properties does control port/hostname but preferably we wouldn't need to configure it.

        Issue Links

          Activity

          jacques.le.roux Jacques Le Roux added a comment -

          Fixed at r1785014, for more information see OFBIZ-9206

          jacques.le.roux Jacques Le Roux added a comment -

          Hi Leonard, please test the patch in OFBIZ-9206, thanks.

          jacques.le.roux Jacques Le Roux added a comment -

          Ok, this will hopefully be this afternoon...

          jacques.le.roux Jacques Le Roux added a comment -

          Thanks Leonard,

          If nobody beats me on it, I'll have a look tomorrow afternoon (UTC)


            People

            • Assignee:
              jacques.le.roux Jacques Le Roux
              Reporter:
              leonardlin Leonard Lin
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development