Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: None
    • Fix Version/s: 16.11.01
    • Component/s: example
    • Labels:
      None

      Description

      Steps to regenerate the issue:
      1. Go to "EXAMPLE" component.
      2. Click on sub-menu "FOP fonts in a PDF"

      _____________________________________________________
      Direct link
      https://localhost:8443/example/control/fonts.pdf
      _____________________________________________________

        [java] 2016-06-13 19:25:34,639 |ttp-nio-8443-exec-10 |ScreenFopViewHandler          |E| Unable to write to OutputStream: org.apache.catalina.connector.ClientAbortException: java.io.IOException: Broken pipe; Screen XSL:FO text was:
          [java] <?xml version="1.0" encoding="UTF-8"?>
      
      [java] 2016-06-13 19:25:35,084 |ttp-nio-8443-exec-10 |ScreenFopViewHandler          |E| Multiple errors rendering FOP
          [java] 2016-06-13 19:25:35,085 |ttp-nio-8443-exec-10 |ControlServlet                |E| Error in request handler: 
          [java] java.lang.IllegalStateException: getOutputStream() has already been called for this response
          [java] at org.apache.catalina.connector.Response.getWriter(Response.java:564) ~[tomcat-8.0.33-catalina.jar:8.0.33]
          [java] at org.apache.catalina.connector.ResponseFacade.getWriter(ResponseFacade.java:212) ~[tomcat-8.0.33-catalina.jar:8.0.33]
          [java] at org.ofbiz.widget.renderer.fo.ScreenFopViewHandler.renderError(ScreenFopViewHandler.java:191) ~[ofbiz-widget.jar:?]
          [java] at org.ofbiz.widget.renderer.fo.ScreenFopViewHandler.render(ScreenFopViewHandler.java:174) ~[ofbiz-widget.jar:?]
          [java] at org.ofbiz.webapp.control.RequestHandler.renderView(RequestHandler.java:1001) ~[ofbiz-webapp.jar:?]
          [java] at org.ofbiz.webapp.control.RequestHandler.doRequest(RequestHandler.java:653) ~[ofbiz-webapp.jar:?]
          [java] at org.ofbiz.webapp.control.ControlServlet.doGet(ControlServlet.java:213) [ofbiz-webapp.jar:?]
          [java] at javax.servlet.http.HttpServlet.service(HttpServlet.java:622) [servlet-api-3.1.jar:?]
          [java] at javax.servlet.http.HttpServlet.service(HttpServlet.java:729) [servlet-api-3.1.jar:?]
      
          
      

        Activity

        deepak.dixit Deepak Dixit added a comment -

        This is org.apache.catalina.connector.ClientAbortException, it means request aborted by client side, So this is not a bug, if user aborted request from client side before server serves request so it throws ClientAbortException

        We can close this issue.

        deepak.dixit Deepak Dixit added a comment -

        Its working fine, Error is related to "Broken Pipe" It is caused by something causing the connection to close. (It is not your application that closed the connection: that would have resulted in a different exception.)

        Its working fine for firefox and chrome.

        jacques.le.roux Jacques Le Roux added a comment -

        Hi Vaibhav, can you still reproduce locally? Because before opening a Jira issue I created this dev ML thread http://markmail.org/message/kgsnhep5zlbljec5

        pandeypranay Pranay Pandey added a comment -

        Hi Vaibhav Jain,

        Please don't assign any issue directly to me, I will definitely pick it up as I get some bandwidth but in the mean time any of the committer can jump in can help you for committing the fix.

        Thanks.


          People

          • Assignee:
            deepak.dixit Deepak Dixit
            Reporter:
            vaibhav.jain Vaibhav Jain
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development